HDU6092 Rikka with Subset(01背包+思路)

Rikka with Subset

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 856    Accepted Submission(s): 422


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has  n  positive  A1An  and their sum is  m . Then for each subset  S  of  A , Yuta calculates the sum of  S

Now, Yuta has got  2n  numbers between  [0,m] . For each  i[0,m] , he counts the number of  i s he got as  Bi .

Yuta shows Rikka the array  Bi  and he wants Rikka to restore  A1An .

It is too difficult for Rikka. Can you help her?  
 

Input
The first line contains a number  t(1t70) , the number of the testcases. 

For each testcase, the first line contains two numbers  n,m(1n50,1m104) .

The second line contains  m+1  numbers  B0Bm(0Bi2n) .
 

Output
For each testcase, print a single line with  n  numbers  A1An .

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.
 

Sample Input
  
  
2 2 3 1 1 1 1 3 3 1 3 3 1
 

Sample Output
  
  
1 2 1 1 1
Hint
In the first sample, $A$ is $[1,2]$. $A$ has four subsets $[],[1],[2],[1,2]$ and the sums of each subset are $0,1,2,3$. So $B=[1,1,1,1]$

题意:给出n和m,下面m+1个数为b数列,Bi 代表A序列中的所有子集之和为i的有Bi个,A序列总和为m,n个元素; 

分析:在很多个较小数字推较大数字的时候,总是要由小向大推,因为小的数字经过组合会产生新的大的,因此在每求出A序列的一部分的时候,用dp[i]记录一下i这个数字会由前面的A组合出多少次,用B[i]-dp[i]就是需要新增的A的个数,好像没用到n。。。

关键点在于,如何让前面的A组合;看成01背包问题,容量为m的背包去装i,初始值dp[0]=1,由于i不断增大,A子集随机组合不会重复

参考博客:传送门

#include<bits/stdc++.h>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long LL;
const int maxn=1e4+10;
int b[maxn],dp[maxn],a[maxn];
int main()
{
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        mem(dp,0);
        mem(a,0);
        scanf("%d%d",&n,&m);
        for(int i=0;i<=m;i++)
        scanf("%d",&b[i]);
        int tot=0;
        dp[0]=1;
        for(int i=1;i<=m;i++)
        {
            int tmp=b[i]-dp[i];//还需添加多少个i
            for(int j=0;j<tmp;j++)
            {
                a[tot++]=i;
                for(int k=m;k>=i;k--)
                {
                    dp[k]+=dp[k-i];
                }
            }
        }
        printf("%d",a[0]);
        for(int i=1;i<tot;i++)
            printf(" %d",a[i]);
        puts("");
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值