HDU 3336 Count the string(kmp next数组的性质)

Count the string

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11337 Accepted Submission(s): 5285

Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: “abab”
The prefixes are: “a”, “ab”, “aba”, “abab”
For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input
1
4
abab

Sample Output
6

next数组的性质:i之前前缀和后缀的最大相同长度,对于本题,可以统计每一个next[i],因为next[i]有值,则前缀和后缀一定匹配了一次,此时前缀与整个串的匹配数+1,然后求总和即可

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
const int N=2e5+10;
const int mod=10007;
int nxt[N],n,rec[N];
char s[N];
void getnxt()
{
    nxt[0]=-1;
    int i=0,j=-1;
    while(i<n)
    {
        if(j==-1||s[i]==s[j])
        {
            nxt[++i]=++j;
        }
        else
            j=nxt[j];
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        scanf("%s",s);
        memset(rec,0,sizeof(rec));
        getnxt();
         for(int i=1;i<=n;i++)
            rec[nxt[i]]++;
            int ans=0;
         for(int i=1;i<=n;i++)
            if(rec[i]>0)
            ans=(ans+rec[i])%mod;
         printf("%d\n",(ans+n)%mod);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值