hdu3460 Ancient Printer(字典树)

The contest is beginning! While preparing the contest, iSea wanted to print the teams’ names separately on a single paper.
Unfortunately, what iSea could find was only an ancient printer: so ancient that you can’t believe it, it only had three kinds of operations:

● ‘a’-‘z’: twenty-six letters you can type
● ‘Del’: delete the last letter if it exists
● ‘Print’: print the word you have typed in the printer

The printer was empty in the beginning, iSea must use the three operations to print all the teams’ name, not necessarily in the order in the input. Each time, he can type letters at the end of printer, or delete the last letter, or print the current word. After printing, the letters are stilling in the printer, you may delete some letters to print the next one, but you needn’t delete the last word’s letters.
iSea wanted to minimize the total number of operations, help him, please.
Input
There are several test cases in the input.

Each test case begin with one integer N (1 ≤ N ≤ 10000), indicating the number of team names.
Then N strings follow, each string only contains lowercases, not empty, and its length is no more than 50.

The input terminates by end of file marker.
Output
For each test case, output one integer, indicating minimum number of operations.
Sample Input
2
freeradiant
freeopen
Sample Output
21

Hint
The sample’s operation is:
f-r-e-e-o-p-e-n-Print-Del-Del-Del-Del-r-a-d-i-a-n-t-Print

通过观察可以发现,最后一个串是不需要删除的,所以当最后一个串最长时,所求答案最小。而几个串的公用子串只有最后一个串的所在集合访问一次,其他集合均为两次,这样就发现规律了,只有最长串访问了一次,其余所有节点均为两次,将所有节点数sum*2,即所有边都访问了两次,减去最长串,然后加上打印数(即有多少个串)即为答案
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int sum;
struct node
{
    node *next[26];
    node()
    {
        for(int i=0; i<26; i++)
            next[i]=NULL;
    }
};
node *root;
void trie_add(char *s)
{
    node *p=root;
    int len=strlen(s);
    for(int i=0; i<len; i++)
    {
        if(p->next[s[i]-'a']==NULL)
        {
            p->next[s[i]-'a']=new node();
            sum++;
        }
        p=p->next[s[i]-'a'];
    }
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        char s[55];
        root=new node();
        sum=0;
        int maxx=0;
        for(int i=0; i<n; i++)
        {
            scanf("%s",s);
            int len=strlen(s);
            if(maxx<len)maxx=len;
            trie_add(s);
        }
        printf("%d\n",sum*2-maxx+n);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值