PAT L2-011 玩转二叉树

题目
给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式

输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例
7
1 2 3 4 5 6 7
4 1 3 2 6 5 7
输出样例
4 6 1 7 5 3 2

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <map>
#include <queue>
#include <stack>
using namespace std;

int pre[35];
int mid[35];
struct Btnode
{
    int x;
    Btnode *left,*right;
    Btnode(){}
    Btnode(int c = 0,Btnode* a = NULL,Btnode* b = NULL)
    {
        x = c;  left = a;   right = b;
    }
};
Btnode* root = NULL;


Btnode* build(int l1,int r1,int l,int r)
{
    if(l > r) return NULL;
    Btnode* now = new Btnode(0);
    now->x = pre[l1];
    int m = 0;
    while(mid[m]!=pre[l1])
        m++;
    int lnum = m - l;
    now->left = build(l1+1,l1+lnum,l,m-1);
    now->right = build(l1+lnum+1,r1,m+1,r);

    return now;
}

int n,num = 1;

int order()
{
    queue< Btnode* > Q;
    Q.push(root);
    while(!Q.empty())
    {
        Btnode* node = Q.front();
        Q.pop();
        if(node->x != 0)
        {
            if(num == n)
                printf("%d",node->x);
            else printf("%d ",node->x);
            num++;
        }
        if(node->right != NULL)
            Q.push(node->right);
        if(node->left != NULL)
            Q.push(node->left);
    }
}
int main()
{

    scanf("%d",&n);
    root = new Btnode(0);
    for(int i = 1; i <= n ;i++)
        scanf("%d",&mid[i]);
    for(int i = 1; i <= n ;i++)
        scanf("%d",&pre[i]);
    root = build(1,n,1,n);
    order();
    printf("\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值