Uva201 Squares

模拟,找正方形有多少个,昨天uva又炸了,今天才看到结果。
终于看到了一个不那么恶心的模拟…课设那题WA了10发…还没过,先放一放再看吧。

题目
A children’s board game consists of a square array of dots that contains lines connecting some of the
pairs of adjacent dots. One part of the game requires that the players count the number of squares of certain sizes that are formed by these lines. For example, in the figure shown below, there are 3 squares — 2 of size 1 and 1 of size 2. (The “size” of a square is the number of lines segments required to form a side.)
Your problem is to write a program that automates the process of counting all the possible squares.

Input
The input file represents a series of game boards. Each board consists of a description of a square array of n
2 dots (where 2 ≤ n ≤ 9) and some interconnecting horizontal and vertical lines. A record for a
single board with n 2 dots and m interconnecting lines is formatted as follows:
Line 1: n the number of dots in a single row or column of the array
Line 2: m the number of interconnecting lines
Each of the next m lines are of one of two types:
H i j indicates a horizontal line in row i which connects the dot in column j to the one to its right in column j + 1 or V i j indicates a vertical line in column i which connects the dot in row j to the one below in row j + 1 Information for each line begins in column 1. The end of input is indicated by end-of-file. The first record of the sample input below represents the board of the square above.

Output
For each record, label the corresponding output with ‘Problem #1’, ‘Problem #2’, and so forth. Output for a record consists of the number of squares of each size on the board, from the smallest to the largest. lf no squares of any size exist, your program should print an appropriate message indicating so. Separate output for successive input records by a line of asterisks between two blank lines, like in the samplebelow.

Sample Input
4
16
H 1 1
H 1 3
H 2 1
H 2 2
H 2 3
H 3 2
H 4 2
H 4 3
V 1 1
V 2 1
V 2 2
V 2 3
V 3 2
V 4 1
V 4 2
V 4 3
2
3
H 1 1
H 2 1
V 2 1
Sample Output
Problem #1
2 square (s) of size 1
1 square (s) of size 2

**********************************

Problem #2
No completed squares can be found.

#include <cstdio>
#include <cstring>
#include <iostream>

using namespace std;
const int maxn = 15;
int h[maxn][maxn];
int v[maxn][maxn];
int ans[300];
int check(int a,int b,int num)
{
    for(int i = b; i < b+num ; i++)
    {
        if(h[a][i] == 0) return 0;
        if(h[a+num][i] == 0) return 0;
    }
    for(int j = a; j < a+num; j++)
    {
        if(v[j][b] == 0) return 0;
        if(v[j][b+num] == 0) return 0;
    }
    return 1;
}


int main()
{
    int n,k;
    int t = 1;
//    freopen("D://in.txt","r",stdin);
    while(~scanf("%d",&n))
    {
        memset(h,0,sizeof(h));
        memset(v,0,sizeof(v));
        memset(ans,0,sizeof(ans));
        scanf("%d",&k);
        while(k--)
        {
            char s[2];
            int a,b;
            scanf("%s",s);
            scanf("%d%d",&a,&b);
            if(s[0] == 'H') h[a][b] = 1;
            else v[b][a] = 1;
        }
        for(int num = 1; num <= n; num++)
        {
            for(int i = 1; i+num <= n; i++)
            {
                for(int j = 1; j+num <= n ; j++)
                    if(check(i,j,num))  ans[num]++;
            }
        }
        if(t!=1)
            printf("\n**********************************\n\n");
        printf("Problem #%d\n\n",t++);
        int flag = 0;
        for(int i = 1; i <= n ;i++)
        {
           if(ans[i] != 0)
           {
                printf("%d square (s) of size %d\n",ans[i],i);
                flag ++;
           }
        }
        if(flag == 0)
            printf("No completed squares can be found.\n");

    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值