Fence Repair(POJ-3253)

Fence Repair
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 44768 Accepted: 14617

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer  N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make  N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 

The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).


题目大意:

        需要把长板切割成指定长度的若干板子,切割所需花费就是板的长度,例如把13米长的板子切割成5和8需要花费13元,问得到所有所需板子花费的最小钱数。例如题目所给,把21的板子切成13和8花了21元,把13切成8和5又花了13元,一共花了34元。

解题思路:

        题目考察哈夫曼树的建立和优先级队列的使用,利用逆向思维,不选择切,而是把零散的板子一点点接成个长板子,先选5和8接成13花13元,再接13和8花了21,总共花34。所以这样思路就很清晰了,从一大堆数中选两个最小的,相加、入队,以此类推, 用answer记录花费,直到队列里就剩一个元素,打印answer。

注意事项:

①题目说有两万个数,每个数都最多有五万,一直累加的话最后数据量会很大。所以建议用long long。

②最后只剩一个元素结束循环,打印结果之后别忘了把那个元素出队。

代码如下:

#include<stdio.h>
#include<queue>
#include<vector>
using namespace std;
struct cmp
{
	bool operator ()(int &a,int &b)
	{
		return a>b;
	}
};
priority_queue<int,vector<int>,greater<int> >q;
int main()
{
	int m,n;
	long long answer;
	while(~scanf("%d",&n))
	{
		answer = 0;
		while(n--)
		{
			scanf("%d",&m);
			q.push(m);
		}
		while(q.size()>1)
		{
			int sum = 0;
			sum+=q.top();
			q.pop();
			sum+=q.top();
			answer+=sum;
			q.pop();
			q.push(sum);
		}
		printf("%lld\n",answer);
		while(!q.empty())q.pop(); 
	} 
	return 0;
}

题目传送门。。。。。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值