编程题B-日期格式

Description


注:本题只需要提交编写的函数部分的代码即可。

将输入的日期格式 月/日/年  修改为 年-月-日的格式输出 。请编写缺少的函数output。

#include<stdio.h>
 #include <iostream>
 using namespace std;
 struct date
 {
     int year;
     int month;
     int day;
 };
 int main()
 {
     struct date vd;
     void output(struct date da);
     scanf("%d/%d/%d",&vd.month,&vd.day,&vd.year);
     output(vd);
     return 0;
 }

Input


月/日/年

Output


年-月-日

Sample Input
6/23/2014

Sample Output
2014-6-23

HINT

#include<stdio.h>
struct date
{
    int year;
    int month;
    int day;
};
int main()
{
    struct date vd;
    void output(struct date da);
    scanf("%d/%d/%d",&vd.month,&vd.day,&vd.year);
    output(vd);
    return 0;
}
void output(struct date da)
{
    printf("%d-%d-%d\n",da.year,da.month,da.day);
}
 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值