小数计算——结构体

Description


小数可以看成是一个点和两个数组成的,因此可以定义成一个小数的结构体,现在请用结构体的知识来计算两个小数相加。

注意:不考虑进位,输入的值都是小数,小数位只有一位。

Input


输入两个小数

Output


输出两个小数的和

Sample Input
1.2
3.4


Sample Output
4.6


HINT

//以下代码自动添加到程序结尾


//c++


int main()

 {

     xiaoshu a,b;

     void add(xiaoshu,xiaoshu);

     cin>>a.head>>a.point>>a.tail;

     cin>>b.head>>b.point>>b.tail;

     add(a,b);

     return 0;

 }


//C语言


int main()

 {

     struct xiaoshu a,b;

     void add(struct xiaoshu,struct xiaoshu);

     scanf("%d%c%d",&a.head,&a.point,&a.tail);

     scanf("%d%c%d",&b.head,&b.point,&b.tail);

     add(a,b);

     return 0;

 }


#include<stdio.h>
#include<string.h>
struct xiaoshu
{
    int head;
    char point;
    int tail;
};
void add(struct xiaoshu a,struct xiaoshu b)
{
    printf("%d.%d\n",a.head+b.head,a.tail+b.tail);
}
int main()
{
    struct xiaoshu a,b;
    void add(struct xiaoshu,struct xiaoshu);
    scanf("%d%c%d",&a.head,&a.point,&a.tail);
    scanf("%d%c%d",&b.head,&b.point,&b.tail);
    add(a,b);
    return 0;
}


 

  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值