Longest Ordered Subsequence - 最长上升子序

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence (  a1a2, ...,  aN) be any sequence (  ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8
Sample Output
4


分析:

最长上升子序:LIS - Longest Increasing Subsequence

首先建立递推关系:dp[i]:=以ai结尾的最长上升子序的列的长度

以ai结尾的上升子序列是:

1)只包含ai的子序列,即长度为1

2)在满足j<i并且aj<ai的以aj结尾的序列中,末尾加上ai,即长度大于等于1

===》得到递推关系:dp[i]=max(1,dp[j]+1)  (i<j且aj<ai)

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int a[1005],dp[1005];
int main(){
    int N;
    scanf("%d",&N);
    for(int i=0;i<N;i++){
        scanf("%d",&a[i]);
    }
    int res=0;
    for(int i=0;i<N;i++){
        dp[i]=1;//以ai结尾的序列长度至少为1
        for(int j=0;j<i;j++){
            if(a[j]<a[i])dp[i]=max(dp[i],dp[j]+1);
        }
        res=max(res,dp[i]);//res选出以a0到aN-1结尾的序列的最大值即为LIS
    }
    printf("%d\n",res);
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值