A multiplication game - poj2505 - 博弈论(找规律)

A multiplication game

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6765 Accepted: 3395

Description

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

Input

Each line of input contains one integer number n.

Output

For each line of input output one line either 
Stan wins. 
or 
Ollie wins. 
assuming that both of them play perfectly.

Sample Input

162
17
34012226

Sample Output

Stan wins.
Ollie wins.
Stan wins.

Source

Waterloo local 2001.09.22

思路:

列举一下可发现:

2-9     Stan胜

9+1 - 9*2  Ollie胜(Stan越想到N,Ollie越不让他达到)

18是Stan必败的点,所以在18*9这个范围内Stan必胜

9*2+1 - 9*2*9 Stan胜

 9*2*9+1 - 9*2*9*2 Ollie胜

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>

using namespace std;
int main(){
	double n;
	while(scanf("%lf",&n)!=EOF){
		while(n>18)n/=18;
		if(n<=9)printf("Stan wins.\n");
		else if(n<=18)printf("Ollie wins.\n");
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值