poj3579 - Median - 求第k大值、二分

Median

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10526 Accepted: 3719

Description

Given N numbers, X1, X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i j N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of m = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, ... , XN, ( Xi ≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

Source

POJ Founder Monthly Contest – 2008.04.13, Lei Tao

思路见代码

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<cmath>
#include<stack>
#include<string>
#include<cstring>
#define ll long long
using namespace std;
const int N=1e5+5;
int a[N];
int n;
ll m;

bool ok(int x){//是否符合有m个差值小于等于x
    int res=0;
    for(int i=0;i<n-1;i++){//以a[i]开始的数对,差值<=x的多少个
        res+=upper_bound(a+i,a+n,a[i]+x)-(a+i)-1;
    }
    return res>=m;
}

int main(){
    while(scanf("%d",&n)!=EOF){
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
        }
        m=(ll)n*(n-1)/2;
        if(m%2)m=(m/2)+1;
        else m/=2;
        sort(a,a+n);
        int left=-1,right=a[n-1]-a[0]+1;
        while(left<right-1){
            int mid=(left+right)/2;//枚举第k大的值
            if(ok(mid))right=mid;//有超过m个值小于mid
            else left=mid;
        }
        printf("%d\n",right);
    }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值