poj3685 - Matrix - 二分套二分

Matrix

Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 8814 Accepted: 2683

Description

Given a N × N matrix A, whose element in the i-th row and j-th column Aij is an number that equals i2 + 100000 × i + j2 - 100000 × j + i × j, you are to find the M-th smallest element in the matrix.

Input

The first line of input is the number of test case.
For each test case there is only one line contains two integers, N(1 ≤ N ≤ 50,000) and M(1 ≤ MN × N). There is a blank line before each test case.

Output

For each test case output the answer on a single line.

Sample Input

12

1 1

2 1

2 2

2 3

2 4

3 1

3 2

3 8

3 9

5 1

5 25

5 10

Sample Output

3
-99993
3
12
100007
-199987
-99993
100019
200013
-399969
400031
-99939

Source

POJ Founder Monthly Contest – 2008.08.31, windy7926778

我也是佛了,开始枚举j,WA了无数发,后来改成枚举i,才过……有什么区别吗???

AC代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<cmath>
#include<stack>
#include<string>
#include<cstring>
#define ll long long
using namespace std;
const ll N=50000;
int a[N];
ll n,m;
ll cal(ll i,ll j){
    return i*i+100000*i+j*j-100000*j+i*j;
}
bool ok(ll x){
    ll cnt=0;
    for(ll j=1;j<=n;j++){
        ll left=0,right=n+1;
        while(left<right-1){
            ll mid=(left+right)/2;
            if(cal(mid,j)<=x)left=mid;
            else right=mid;
        }
        cnt+=left;
    }
    return cnt>=m;
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%lld%lld",&n,&m);
        ll right=1e12,left=-1e12;
        while(left<right-1){//枚举第m大元素的值
            ll mid=(left+right)/2;
            if(ok(mid))right=mid;
            else left=mid;
        }
        printf("%lld\n",right);
    }
}

WA的代码:

bool ok(ll x){
    ll cnt=0;
    for(ll i=1;i<=n;i++){
        ll left=0,right=n+1;
        while(left<right-1){
            ll mid=(left+right)/2;
            if(cal(i,mid)<=x)right=mid;
            else left=mid;
        }
        cnt+=(n-right+1);
    }
    return cnt>=m;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值