poj3468 - A Simple Problem with Integers - 树状数组(区间更新、区间查询)

A Simple Problem with Integers

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 168624 Accepted: 51960
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

思路:

(写了好多bug才AC……)

原数组    a:1  2  3  4  5  6  7  8  9  10

差分数组d:1  1  1  1  1  1  1  1  1  1          (d[i]=a[i]-a[i-1])

此时我们要求元素a[i]:a[i]=\sum_{j=1}^{i}b[j]

那么a[1]到a[i]的和:sum[i]=\sum_{j=1}^{i}a[j]=i*d[1]+(i-1)*d[2]+(i-2)*d[3]+...+1*d[i]

                                             =\sum_{j=1}^{i}(i-j+1)*d[j]

                                             =(i+1)\sum_{j=1}^{i}d[j]-\sum_{j=1}^{i}d[j]*j

                                            

所以设两个树状数组sum1[i]=\sum_{j=1}^{i}d[j]        与       sum2[i]=\sum_{j=1}^{i}d[j]*j

这两个数组的用法,类比普通的树状数组,进行更新和查询。

代码如下:

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<cstring>
#include<set>
#include<map>
#include<queue>
#include<vector>
#include<cmath>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define ll long long
using namespace std;
const int N=100005;
const int INF=0x3f3f3f3f;

ll a[N],d[N],sum1[N],sum2[N],n;

ll lowbit(ll x){
    return x&(-x);
}

ll sum(ll x){
    ll res=0;
    ll p=x;
    while(x>0){
        res+=(p+1)*sum1[x]-sum2[x];
        x-=lowbit(x);
    }
    return res;
}

ll range_ask(ll l,ll r){
    return sum(r)-sum(l-1);
}

void add(ll x,ll m){
    ll x1=x;
    while(x<=n){
        sum1[x]+=m;
        sum2[x]+=x1*m;
        x+=lowbit(x);
    }
}

void range_add(ll l,ll r,ll x){
    add(l,x);
    add(r+1,-x);
}

int main(){
    int q;
    scanf("%lld%d",&n,&q);
    for(ll i=1;i<=n;i++){
        scanf("%lld",&a[i]);
        d[i]=a[i]-a[i-1];
    }
    for(ll i=1;i<=n;i++){//赋初值
        add(i,d[i]);
    }
    char s[5];
    ll l,r;
    while(q--){
        scanf("%s%lld%lld",s,&l,&r);
        if(s[0]=='Q'){
            ll ans=range_ask(l,r);
            printf("%lld\n",ans);
        }
        else{
            ll x;
            scanf("%lld",&x);
            range_add(l,r,x);
        }
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值