[POJ](3050)Hopscotch---- 裸dfs+set容器

Description

The cows play the child’s game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).

Determine the count of the number of distinct integers that can be created in this manner.

Input

  • Lines 1..5: The grid, five integers per line

Output

  • Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS:
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

题意:给你一个5x5的方格图,玩跳房子游戏,可以向上、下、左、右四个方向跳,算上第一次,一共跳6次,问可以用这种方式创建的不同整数的数量。

思路:由于没有说起始位置,那么我们可以枚举所有位置深搜,每当跳了6次,就把它放到set里面,防止重复。最后set.size()的值就是答案。

AC代码:

#include<iostream>
#include<cstdio>
#include<set>
#include<algorithm>
using namespace std;
int mmap[10][10];
int dir[4][2] = {{1,0},{-1,0},{0,1},{0,-1}};
set<int>s;//集合容器,每个元素只能出现一次
void dfs(int x,int y,int step,int number)
{
    if(step == 5)
    {
        s.insert(number);
        return;
    }
    for(int i=0;i<4;i++)
    {
        int nx = x+dir[i][0];
        int ny = y+dir[i][1];
        if(nx>=0 && nx<5 && ny>=0 && ny<5)
            dfs(nx,ny,step+1,number*10+mmap[nx][ny]);
    }
}
int main()
{
    ios_base::sync_with_stdio(false);
    cin.tie(NULL),cout.tie(NULL);
    for(int i=0;i<5;i++)
    {
        for(int j=0;j<5;j++)
            cin>>mmap[i][j];
    }
    for(int i=0;i<5;i++)
    {
        for(int j=0;j<5;j++)
            dfs(i,j,0,mmap[i][j]);
    }
    cout<<s.size()<<endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值