杭电OJ1097(快速幂取模) java

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 48021    Accepted Submission(s): 17617


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b's last digit number.
 

Sample Input
 
 
7 66 8 800
 

Sample Output
 
 
9 6
 

Author
eddy
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1106  1003  1002  1159  1042 



import java.util.Scanner;



public class Main {


static int quickMod(int a, int b, int c)  
{  
   int ans = 1;
   a = a%c;
   while (b!=0)  
   {  
 
       if ((b&1)==1)  
           ans = (ans * a) % c;  
       b >>=1;  
       a = (a * a) % c;  
   }  
   return ans;  
}  

public static void main(String[] args) {
Scanner in = new Scanner(System.in);
while(in.hasNext()) {
 int a = in.nextInt();
 int b = in.nextInt();
 System.out.println(quickMod(a, b, 10));
}


}}

知识点: b>>=1   b&1 百度位运算符:https://jingyan.baidu.com/article/1612d5008ff5b7e20f1eee4c.html

对于java来说 逻辑右移的符号为(>>> 不带符号对数字除以二)和算数右移(>>带符号除以二)  c语言则根据编译器判断,有符号就带符号。

& 与运算,因为 1 的二进制最后一位为 1 ,所以对 1 按位与运算,则判断这个数是否为奇数,是奇数&1则为1,是偶数&1则为0.

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值