android开发的adb不支持,adt和sdk不匹配,AVD打不开等问题

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37789800/article/details/78009068

android说明

android开发初期,电脑需要一些软件和插件;jdk,eclipsean安装,sdk的安装,ADT插件。
关于这些资源大家在网上搜一下会有很多,基本的安装顺序以及初学者配置,选择的等一系列都会有解答,我在这里给出的是一般电脑不兼容一些插件,或一些我遇见的不知原因的bug,但是再往上没有找到答案的解决方法。

adb问题:

安装好sdk后,需要输入adb version验证是否安装成功,当然如果你看到这个,证明你很有可能失败了。
1.我之前用的是win10系统,这个问题比较好解决,从platform-tools(也有可能在tools)文件夹中,你会找到一个adb文件,将这个文件放在c盘windows/system32的里面,问题一般就能解决。
2.前几天点背,系统蹦了,退回到原来的win8,这个问题又来了,以前的方法不好使了,我将adb文件复制到上述的路径下,在cmd输入adb version后,提示缺少一个AdbWinApi.dll文件,上网查了,也从sdk原有的pltform-tools和tools文件夹找到了此文件,但是,放到系统的文件夹下system32,system都不好使,大家可以是一下,可能我是特例,于是从网上终于找到一个好使得AdbWinApi.dll文件,放到C:/wimdows/system目录下,解决了,这个文件下载地址在下方,需要的自行下载。

adt和所sdk不匹配和AVD的问题

相信能坐下来看这个问题的人,一定遇见过,如此的Error:
Failed to load C:\Program Files (x86)\Android\android-sdk\build-tools\26.0.0-preview\lib\dx.jar

Unable to build: the file dx.jar was not loaded from the SDK folder.
有没有炸的了感觉,我是被弄得冒烟了,尤其那几天系统还出了问题。
言归正传:这个问题,一开始你可能都会去搜这个所谓的dx.jar文件,然后就发现根本他妈的没用,放在哪都不好使。
正确的解决方法:根本在于版本的问题,我的ADT是23.0.6,而我的SDK是25.2.5,所以一样不行,所以我的解决办法就是点开SDK manager,下载tools里面的那个与你的ADT版本对应的building-tools的版本,我下了23.0.3的,把他们放在原先的build-tools下面就好了(下完也就在那)
注意:把原先的不管你是什么版本的(就是那个26.0.1),把他们移除那个原先的问题,软件会默认选择最新的,你不移走就相当于没弄。
以上是我觉得比较大的和最头疼的问题,如果大家还有别的什么bug,可以在下面留言,尽我所能给大家解决。

没有更多推荐了,返回首页