大笨钟

大笨钟

微博上有个自称“大笨钟V”的家伙,每天敲钟催促码农们爱惜身体早点睡觉。不过由于笨钟自己作息也不是很规律,所以敲钟并不定时。一般敲钟的点数是根据敲钟时间而定的,如果正好在某个整点敲,那么“当”数就等于那个整点数;如果过了整点,就敲下一个整点数。另外,虽然一天有24小时,钟却是只在后半天敲1~12下。例如在23:00敲钟,就是“当当当当当当当当当当当”,而到了23:01就会是“当当当当当当当当当当当当”。在午夜00:00到中午12:00期间(端点时间包括在内),笨钟是不敲的。

下面就请你写个程序,根据当前时间替大笨钟敲钟。

输入格式:

输入第一行按照hh:mm的格式给出当前时间。其中hh是小时,在00到23之间;mm是分钟,在00到59之间。

输出格式:

根据当前时间替大笨钟敲钟,即在一行中输出相应数量个Dang。如果不是敲钟期,则输出:

Only hh:mm.  Too early to Dang.

其中hh:mm是输入的时间。

输入样例1:

19:05

输出样例1:

DangDangDangDangDangDangDangDang

输入样例2:

07:05

输出样例2:

Only 07:05.  Too early to Dang.
/*******************************************************************************/
/*  ___________                ___        ___             ___                  */
/*  /_______   /\              /  /\      /  /\           /  /\                */
/*   \      /  /  \            /  /  \    /  /  \         /  /  \              */
/*     \____/  /   /           /  /   /   /  /   /        /  /   /             */
/*          /  /   /           /  /___/___/  /   /        /  /   /             */
/*          /  /   /           /  ________   /   /        /  /   /             */
/*          /  /   /           /  /\      /  /   /        /  /   /             */
/*          /  /___/____       /  /  \____/  /   /        /  /___/___          */
/*          /___________/\     /__/   /   /__/   /        /___________/\       */
/*           \           \ \    \  \  /    \  \  /         \           \ \     */
/*             \___________\/     \__\/      \__\/           \___________\/    */
/*                                                                             */
/*******************************************************************************/
#include <stdio.h>
#include <iostream>
#include <cmath>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
#include <set>
#include <vector>
#define mem0(arr) memset(arr,0,sizeof(arr))
using namespace std;
int main()
{
	int a, b;
	scanf("%d:%d", &a, &b);
	if (a < 12 || (a == 12 && b == 0))
	{
		printf("Only %02d:%02d.  Too early to Dang.\n", a, b);
	}
	else
	{
		int ct = a - 12;
		if (b > 0)ct++;
		for (int i = 0; i < ct; i++)
			printf("Dang");
		cout << endl;
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值