HDU3874 (树状数组+离线操作)

Mery has a beautiful necklace. The necklace is made up of N magic balls. Each ball has a beautiful value. The balls with the same beautiful value look the same, so if two or more balls have the same beautiful value, we just count it once. We define the beautiful value of some interval x,y as F(x,y). F(x,y) is calculated as the sum of the beautiful value from the xth ball to the yth ball and the same value is ONLY COUNTED ONCE. For example, if the necklace is 1 1 1 2 3 1, we have F(1,3)=1, F(2,4)=3, F(2,6)=6.

Now Mery thinks the necklace is too long. She plans to take some continuous part of the necklace to build a new one. She wants to know each of the beautiful value of M continuous parts of the necklace. She will give you M intervals L,R










(1<=L<=R<=N) and you must tell her F(L,R) of them.
Input
The first line is T(T<=10), representing the number of test cases.
  For each case, the first line is a number N,1 <=N <=50000, indicating the number of the magic balls. The second line contains N non-negative integer numbers not greater 1000000, representing the beautiful value of the N balls. The third line has a number M, 1 <=M <=200000, meaning the nunber of the queries. Each of the next M lines contains L and R, the query.
Output
For each query, output a line contains an integer number, representing the result of the query.
Sample Input
2
6
1 2 3 4 3 5
3
1 2
3 5
2 6
6
1 1 1 2 3 5
3
1 1
2 4
3 5
Sample Output

3
7
14
1
3
6 

题意:给一组数据,每次查询一个区间内的和,相同的数据智能计算一次。

分析:查询一个区间和线段树或者树状数组。一个数据只能计算一次,有点麻烦。这个时候应该用离线操作。

           先把要查询的数据按照区间右端点,从小到大排序。用一个last数组记录每个数据第一次出现的位置。

         每次查询前先遍历一次这个区间,对于不是第一次出现的数据。先减去第一次出现这个数据的位置的值。

       然后将这个位置标记为第一次出现。由于区间已排好序,从左至右依次。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int last[1000200],n,m,val[200050];
long long ans[200050],seg[50050];
struct node
{
    int b,e,index;
}a[200050];
bool cmp(node aa,node bb)
{
    return aa.e<bb.e;
}
void add(int i,int v)
{
    while(i<=n)
    {
        seg[i]+=v;
        i+=(i&-i);
    }
}
long long sum(int i)
{
    long long anss=0;
    while(i>0)
    {
        anss+=seg[i];
        i-=(i&-i);
    }
    return anss;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(last,0,sizeof(last));
        memset(seg,0,sizeof(seg));
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&val[i]);
            add(i,val[i]);
            if(!last[val[i]])last[val[i]]=i;
        }
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&a[i].b,&a[i].e);
            a[i].index=i;
        }
        sort(a+1,a+m+1,cmp);
        int rg=1;
        for(int i=1;i<=m;i++)
        {
            for(int j=rg;j<=a[i].e;j++)
            {
                if(last[val[j]]!=j)
                {
                    add(last[val[j]],-val[j]);
                    last[val[j]]=j;
                }
            }
            rg=a[i].e;
            ans[a[i].index]=sum(a[i].e)-sum(a[i].b-1);
        }
        for(int i=1;i<=m;i++)
         printf("%lld\n",ans[i]);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值