stack or queue

3:stack or queue

总时间限制: 
1000ms 
内存限制: 
65535kB
描述

栈和队列都是常用的线性结构,它们都提供两个操作:

Push:加入一个元素。

Pop:弹出一个元素。

不同的是,栈是”先进后出”,而队列则是”先进先出”。

给出一个线性结构的进出顺序,判定这个结构是栈还是队列。

输入
第一行输入一个整数t,代表有t组测试数据
对于每组测试数据,第一行输入一个整数n,代表操作的次数。
随后输入n行,每行包含两个整数 type val。
当type = 1时,表示该次操作为push操作,val表示进入的数字。当type=2时,表示该次操作为pop操作,val代表出来的数字。
3<=n<=2000
输出
每组测试数据输出一行。
输出改组数据对应的线性结构,”Stack” 或者 “Queue”。
题目保证是栈或者队列的一种。
样例输入
261 11 21 32 32 22 141 11 22 12 2
样例输出
StackQueue

#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iomanip>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>
using namespace std;
string Struct;
bool Hasfind;
int In[2005];
int Out[2005];
int main()
{
	int Test;
	cin>>Test;
	while(Test--)
	{
		int n,a,b,Innum=0,Outnum=0;
		cin>>n;
		for(int i=0;i<n;++i)
		{
			cin>>a>>b;
			if(a==1)
			{
				In[Innum++]=b;
			}
			else
			{
				Out[Outnum++]=b;
			}
		}
		int num=min(Innum,Outnum);
		Hasfind=false;
		for(int i=0;i<num;++i)
		{
			if(In[i]!=Out[i])
			{
				Struct="Stack";
				Hasfind=true;
				break;
			}
		}
		if(!Hasfind) Struct="Queue";
		cout<<Struct<<endl;
	} 
	return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值