poj 1018:Communication System

1018:Communication System

总时间限制: 
1000ms 
内存限制: 
65536kB
描述
We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices. 
By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.
输入
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.
输出
Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point.
样例输入
1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110
样例输出
0.649
来源
Tehran 2002, First Iran Nationwide Internet Programming Contest

题目大意:一个通信系统需要好多种设备,每种设备有许多种材质可选,,不同材质的同种设备带宽和价格不同,最终带宽B是所有设备中带宽最低的带宽,价格P是所有设备价格总和,要使得B/P最大
枚举最低带宽即可。

#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iomanip>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>
using namespace std;
struct Device
{
	int B,P;
}D[105][105];
int m[105]={0};
int main()
{
	int Test;
	cin>>Test;
	while(Test--) 
	{
		int n,Max=0,Min=0x7fffffff/2;
		cin>>n;
		for(int i=0;i<n;++i)
		{
			cin>>m[i];
			for(int j=0;j<m[i];++j)
			{
				cin>>D[i][j].B>>D[i][j].P;
				if(Max<D[i][j].B)Max=D[i][j].B;
				if(Min>D[i][j].B)Min=D[i][j].B;
			}
		}
		double ans=0;
		for(int b=Min;b<=Max;++b)
		{
			double sump=0;
			for(int i=0;i<n;++i)
			{
				double p=0x7fffffff/2;
				for(int j=0;j<m[i];++j)
				{
					if(D[i][j].B>=b&&D[i][j].P<p)
					{
							p=D[i][j].P;
					}
				}
				sump+=p;
			}
			if(ans<b/sump)ans=b/sump;
		}
		cout<<fixed<<setprecision(3)<<ans<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值