Problem A: 第一个类

HomeWeb BoardProblemSetStandingStatusStatistics

Problem A: 第一个类

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 730   Solved: 669
[ Submit][ Status][ Web Board]

Description

定义一个Thing类,只有1个字符串属性name,定义其构造函数和析构函数,分别输出样例所示的内容。

Input

一个不包含空白符的字符串。

Output

见样例。

Sample Input

Truck

Sample Output

Construct a thing CarConstruct a thing TruckDestroy a thing TruckDestroy a thing Car

HINT

Append Code

[ Submit][ Status][ Web Board]
#include <iostream>
#include <iomanip>
#include <cstring>
#include <cmath>
using namespace std;
class Thing
{
private:
    string name;
public:
    Thing(){ }
    Thing(string n):name(n) {cout << "Construct a thing " << name << endl; }
    ~Thing(){ cout << "Destroy a thing " << name << endl;}
};
int main()
{
    Thing A("Car");
    string str;
    cin>>str;
    Thing B(str);
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值