一元多项式求导

设计函数求一元多项式的导数。

输入格式:

以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。

输出格式:

以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。

输入样例:

3 4 -5 2 6 1 -2 0

输出样例:

12 3 -10 1 6 0

#include <bits/stdc++.h>
typedef struct Type
{
        int num, index, der;
        struct Type *next;
}Type;
int main()
{
    Type *L, *rearptr, *curptr;
    int nm, ide;
    L = rearptr = (Type *)malloc(sizeof(Type));
    while(scanf("%d %d", &nm, &ide) != EOF)
    {
        curptr = (Type *)malloc(sizeof(Type));
        curptr->num = nm, curptr->index = ide;
        curptr->der = nm * ide;
        rearptr->next = curptr;
        rearptr = curptr;
    }
    rearptr->next = NULL;
    Type *p = L->next;
    int dex = 0;
    while(p)
    {
        if(p->index - 1 >= 0)
        {
            if(dex)
                printf(" ");
            printf("%d %d", p->der, p->index-1);
            dex++;
        }
        p = p->next;
    }
    if(L->next == NULL || L->next->index == 0)
        printf("0 0");
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值