gitbook pdf docker

需要增加的环境变量:

  1. export PUPPETEER_SKIP_DOWNLOAD=true
    export OPENSSL_CONF=/etc/ssl/

需要保证的版本号:

  npm: 6.13.4
  node:10.19.0
  gitbook:  CLI version: 2.3.2
            GitBook version: 3.2.3
  svgexport: 0.3.2
  确保版本一致,否则会因为各种版本的问题出现各种bug

在已经有maven和java的Ubuntu镜像中,安装的gitbook的Dockfile

   FROM docker.bizseer.com/library/maven:3-jdk-8
  ARG VERSION=3.2.3
 LABEL version=$VERSION
 ENV PUPPETEER_SKIP_DOWNLOAD=true
 ENV OPENSSL_CONF=/etc/ssl/
 RUN apt-get update && apt-get install -y apt-transport-https && \
    curl --silent --location https://deb.nodesource.com/setup_10.x | bash - && \
    apt-get install --yes nodejs && \
    apt-get install --yes build-essential && \
    npm install gitbook-cli -g && \
    npm -g install npm@6.13.4 && \
    apt-get install --yes calibre && \
    npm install puppeteer --unsafe-perm=true --allow-root && \
    npm install svgexport@0.3.2 -g --unsafe-perm=true && \
    apt-get clean && \
    apt-get autoclean && \
    gitbook fetch ${VERSION} && \
    npm cache clear --force

COPY settings.xml /root/.m2/
EXPOSE  8080 4000 35729
CMD sleep infinity

最后:由于gitbook 开源版已经不维护,因为已经有了一个收费的在线的gitbook(相当的贵)有的坑 无人进行修改,所以不建议使用,可以使用mkdocs。(macdocs刚开始使用具体有没有坑不清楚啊)

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页