HDU 6401 - Magic Square(模拟)

Magic Square

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 440    Accepted Submission(s): 362


 

Problem Description

A magic square is a 3×3 square, where each element is a single digit between 1 and 9 inclusive, and each digit appears exactly once. There are 4 different contiguous 2×2 subsquares in a magic squares, which are labeled from 1 to 4 as the following figure shows. These 2×2 subsquares can be rotated. We use the label of the subsquare with an uppercase letter to represent a rotation. If we rotate the subsquare clockwise, the letter is 'C'; if we rotate it counterclockwise, the letter is 'R'. The following figure shows two different rotations.



Now, given the initial state of a magic square and a sequence of rotations, please print the final state of the magic square after these rotations are performed.

 

 

Input

The first line of input is a single integer T (1≤T≤100), the number of test cases.

Each test case begins with a single integer n (1≤n≤100), the number of rotations. It is then followed by a 3×3 square, where every digit between 1 and 9 inclusive appears exactly once, representing the initial state of the magic square. The following n lines describe the sequence of rotations.

The test data guarantees that the input is valid.

 

 

Output

For each test case, display a 3×3 square, denoting the final state of the magic square.

 

 

Sample Input

 

1 2 123 456 789 1C 4R

 

Sample Output

 

413 569 728

 

思路

这个题的意思就是给你一个3x3的矩阵,给你一条指令,例如1C,意思就是将图示中1这个2x2的小矩阵顺时针旋转一次,1R,意思就是将图示中1这个2x2的小矩阵逆时针旋转一次。

这个题比较水,属于模拟题,那么水题就用水题的做法做,所以代码有点长。

代码

#include<cstdio>

using namespace std;

int main(){
    int t;
    scanf("%d",&t);

    while(t--){
        int n;
        scanf("%d",&n);

        int a[3][3],i=0;
        for(int i=0;i<3;i++){
            getchar();
            for(int j=0;j<3;j++){
                char c = getchar();
                a[i][j] = c - '0';
            }
        }
        getchar();

        while(n--){
            int t;
            int p = getchar() - '0';
            char q = getchar();
            getchar();
            if(q == 'C'){
                if(p == 1){
                    t = a[0][0];
                    a[0][0] = a[1][0];
                    a[1][0] = a[1][1];
                    a[1][1] = a[0][1];
                    a[0][1] = t;
                }else if(p == 2){
                    t=a[0][1];
                    a[0][1]=a[1][1];
                    a[1][1]=a[1][2];
                    a[1][2]=a[0][2];
                    a[0][2]=t;
                }else if(p == 3){
                    t=a[1][0];
                    a[1][0]=a[2][0];
                    a[2][0]=a[2][1];
                    a[2][1]=a[1][1];
                    a[1][1]=t;
                }else if(p == 4){
                    t=a[1][1];
                    a[1][1]=a[2][1];
                    a[2][1]=a[2][2];
                    a[2][2]=a[1][2];
                    a[1][2]=t;
                }
            }else{
                if(p == 1){
                    t=a[0][0];
                    a[0][0]=a[0][1];
                    a[0][1]=a[1][1];
                    a[1][1]=a[1][0];
                    a[1][0]=t;
                }else if(p == 2){
                    t=a[0][1];
                    a[0][1]=a[0][2];
                    a[0][2]=a[1][2];
                    a[1][2]=a[1][1];
                    a[1][1]=t;
                }else if(p == 3){
                    t=a[1][0];
                    a[1][0]=a[1][1];
                    a[1][1]=a[2][1];
                    a[2][1]=a[2][0];
                    a[2][0]=t;
                }else if(p == 4){
                    t=a[1][1];a[1][1]=a[1][2];a[1][2]=a[2][2];a[2][2]=a[2][1];a[2][1]=t;
                }
            }
        }

        for(int i=0;i<3;i++){
            for(int j=0;j<3;j++){
                printf("%d",a[i][j]);
            }
            printf("\n");

        }
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Honyelchak

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值