Hdu 1575-Tr A 矩阵快速幂

题目

Tr A

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7316    Accepted Submission(s): 5370


 

Problem Description

A为一个方阵,则Tr A表示A的迹(就是主对角线上各项的和),现要求Tr(A^k)%9973。

 

 

Input

数据的第一行是一个T,表示有T组数据。
每组数据的第一行有n(2 <= n <= 10)和k(2 <= k < 10^9)两个数据。接下来有n行,每行有n个数据,每个数据的范围是[0,9],表示方阵A的内容。

 

 

Output

对应每组数据,输出Tr(A^k)%9973。

 

 

Sample Input

 

2 2 2 1 0 0 1 3 99999999 1 2 3 4 5 6 7 8 9

 

 

Sample Output

 

2 2686

题目链接http://acm.hdu.edu.cn/showproblem.php?pid=1575

思路

矩阵快速幂的入门题目,比较水。

代码

#include<cstdio>
#include<cstring>

using namespace std;

const int maxn = 15;
const int m = 9973;

int n,k;

struct Matrix{
    int a[maxn][maxn];
};

Matrix mul(Matrix A,Matrix B){
    Matrix res;
    for(int i=0;i < n;i++){
        for(int j=0;j < n;j++){
            res.a[i][j] = 0;
            for(int k=0;k < n;k++){
                res.a[i][j] =  (res.a[i][j] + (A.a[i][k] * B.a[k][j])%m)%m;
            }
        }
    }
    return res;
}

Matrix poww(Matrix A,Matrix B,int b){
    while(b){
        if(b&1)B = mul(B,A);
        b >>= 1;
        A = mul(A,A);
    }
    return B;
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&k);
        Matrix p,q;
        for(int i=0;i < n;i++){
            for(int j=0;j < n;j++){
                scanf("%d",&p.a[i][j]);
                q.a[i][j] = p.a[i][j];
            }
        }
        p = poww(p,q,k-1);
        int res = 0;
        for(int i=0;i < n;i++){
                res = (res + p.a[i][i])%m;
        }
        printf("%d\n",res);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Honyelchak

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值