【HDU1757】A Simple Math Problem

                            A Simple Math Problem

                        Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                            Total Submission(s): 6500    Accepted Submission(s): 3989

 

Problem Description

Lele now is thinking about a simple function f(x).
If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .
Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.

 

Input

The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.

 

Output

For each case, output f(k) % m in one line.

 

Sample Input

10 9999

1 1 1 1 1 1 1 1 1 1

20 500

1 0 1 0 1 0 1 0 1 0

 

Sample Output

45

104

解析:

       矩阵快速幂。稍微推一下就出来了。

 

代码:

#include <bits/stdc++.h>
using namespace std;

const int Max=12;
int n,mod;
int ans[Max],a[Max][Max];

inline int get_int()
{
	int x=0,f=1;
	char c;
	for(c=getchar();(!isdigit(c))&&(c!='-');c=getchar());
	if(c=='-') f=-1,c=getchar();
	for(;isdigit(c);c=getchar()) x=(x<<3)+(x<<1)+c-'0';
	return x*f;
}
inline void print(int x)
{
	if(x>9) print(x/10);
	putchar('0'+x%10);
}

inline void mul(int ans[Max],int a[Max][Max])
{
	int c[Max];
	memset(c,0,sizeof(c));
	for(int j=1;j<=10;j++)
	  for(int k=1;k<=10;k++)
	    c[j]=(c[j]+ans[k]*a[k][j])%mod;
	memcpy(ans,c,sizeof(c));
}

inline void mulself(int a[Max][Max])
{
	int c[Max][Max];
	memset(c,0,sizeof(c));
	for(int i=1;i<=10;i++)
	  for(int j=1;j<=10;j++)
	    for(int k=1;k<=10;k++)
	      c[i][j]=(c[i][j]+a[i][k]*a[k][j])%mod;
	memcpy(a,c,sizeof(c));
}

inline void solve(int n)
{
	while(n)
	{
	  if(n&1) mul(ans,a);
	  n>>=1;
	  mulself(a);
	}
}

int main()
{
	while(~scanf("%d%d",&n,&mod))
	{
	  memset(a,0,sizeof(a)),memset(ans,0,sizeof(ans));
	  if(n<10) {print(n),putchar('\n');continue;}
	  for(int i=1;i<=10;i++) ans[i]=10-i;
	  for(int i=1;i<=10;i++) a[i][1]=get_int();
	  for(int i=1;i<=10;i++) a[i][i+1]=1;
	  solve(n-9);
	  print(ans[1]),putchar('\n');
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值