PAT 1104 Sum of Number Segments (20 分) 数列阶梯式相加(AC的代码 和 有错误的代码) 燚

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10​5​​. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4
0.1 0.2 0.3 0.4

Sample Output:

5.00

题目意思很简单 不用解释。

我有两种思路,第一种AC了,但第二种不知道错在哪,希望有大神指正错误,在下感激不尽

AC的思路:以样例为例将问题具体化

                    0.1     0.3     0.6    1.0                   

                              0.2     0.5    0.9 

                                        0.3     0.7

                                                  0.4

含0.1 的元素只出现在第一行的n个数中,含0.2的出现在第一行和第二行的2*(n-1)个数中,以此类推0.3 为3*(n-2)..........。

由以上递推式可求出解

AC代码:

#include<cstdio>
int main(){
	double sum=0;
	int n;
	scanf("%d",&n);
	double temp;
	for(int i=0;i<n;i++){
		scanf("%lf",&temp);
		sum+=temp*(i+1)*(n-i);
	}
	printf("%.2lf",sum);
}

有错误的代码(发现错误的朋友请留个言在下感激不尽)

     思路:

                    0.1     0.3     0.6    1.0                   

                              0.2     0.5    0.9 

                                        0.3     0.7

                                                  0.4

在输入的时候利用一个临时变量temp求出第一行的和 sum,并且将 0.1   0.2   0.3   0.4  放入一个数组里,然后令temp=sum;

第二行的和等于temp减去4个0.1  然后更新temp的值为第二行的和,sum+=temp 。第三行的和等于temp减去4个0.2.......。以此类推理论上可求得解(但倒数第二个示例过不去)

#include<iostream>
#include<vector>
using namespace std;
vector<double>number;
int main() {
	int n;
	cin >> n;
	number.resize(n);
	double sum = 0,temp=0;
	for (int i = 0; i < n; i++) {
		scanf("%lf", &number[i]);
		temp+=number[i];
		sum+=temp;
	}
	temp=sum;
	for ( int i = 0; i <n-1; i++) {
		temp-=(number[i]*(n-i));
		sum+=temp;
	}
	printf("%.2lf", sum);
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值