PTA 1095 解码PAT准考证 C++实现

题目来源:PAT (Basic Level) Practice 1095

PAT 准考证号由 4 部分组成:
第 1 位是级别,即 T 代表顶级;A 代表甲级;B 代表乙级;
第 2~4 位是考场编号,范围从 101 到 999;
第 5~10 位是考试日期,格式为年、月、日顺次各占 2 位;
最后 11~13 位是考生编号,范围从 000 到 999。
现给定一系列考生的准考证号和他们的成绩,请你按照要求输出各种统计信息。

输入格式:

输入首先在一行中给出两个正整数 N(≤10^​4​)和 M(≤100),分别为考生人数和统计要求的个数。
接下来 N 行,每行给出一个考生的准考证号和其分数(在区间 [0,100] 内的整数),其间以空格分隔。
考生信息之后,再给出 M 行,每行给出一个统计要求,格式为:类型 指令,其中

  • 类型 为 1 表示要求按分数非升序输出某个指定级别的考生的成绩,对应的 指令 则给出代表指定级别的字母;
  • 类型 为 2 表示要求将某指定考场的考生人数和总分统计输出,对应的 指令 则给出指定考场的编号;
  • 类型 为 3 表示要求将某指定日期的考生人数分考场统计输出,对应的 指令 则给出指定日期,格式与准考证上日期相同。
输出格式:

对每项统计要求,首先在一行中输出 Case #: 要求,其中 # 是该项要求的编号,从 1 开始;要求 即复制输入给出的要求。随后输出相应的统计结果:

  • 类型 为 1 的指令,输出格式与输入的考生信息格式相同,即 准考证号 成绩。对于分数并列的考生,按其准考证号的字典序递增输出(题目保证无重复准考证号);
  • 类型 为 2 的指令,按 人数 总分 的格式输出;
  • 类型 为 3 的指令,输出按人数非递增顺序,格式为 考场编号 总人数。若人数并列则按考场编号递增顺序输出。

如果查询结果为空,则输出 NA。

输入样例:
8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999
输出样例:
Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

题目分析:

本题限时200ms,通过提交后的数据看出测试点3的运行时间长,是一组大数据,为了防止运行超时,可以考虑结合使用map和vector类,同时在应对类型3指令的时候使用无序的map更能节省时间,否则会超时,最后输出时使用printf也比cout更高效。

代码实现:

#include<iostream>
#include<algorithm>
#include<string>
#include<vector>
#include<cmath>
#include<iomanip>
#include<map>
#include<set>
#include<cmath>
#include<unordered_map>    //包含无序map类的头文件
using namespace std;
bool compare(const pair<string,int> &p1,const pair<string,int> &p2)
{
	return p1.second != p2.second ? p1.second > p2.second:p1.first < p2.first;
}
int main()
{
	int N, M, count = 1;
	cin >> N >> M;
	map<string, int> stu;         //将准考证号与成绩关联并存储
	map<string, int>::iterator iter;
	vector<pair<string, int> > arr;
	vector<pair<string, int> >::iterator item;
	while (N--)
	{
		string s;
		int a;
		cin >> s >> a;
		stu[s] = a;
	}
	for (iter = stu.begin(); iter != stu.end(); iter++)
		arr.push_back(make_pair(iter->first, iter->second));     //由于map类无法使用sort排序,所以存入vector类进行排序
	sort(arr.begin(), arr.end(), compare);
	while (M--)
	{
		int a;
		string s;
		cin >> a >> s;
		printf("Case %d: %d %s\n", count, a, s.c_str());
		if (a == 1)
		{
			int flag = 0;
			for (item = arr.begin(); item != arr.end(); item++)
			{
				string temp = item->first.substr(0, 1);      //获取准考证的第一个字符
				if (temp == s)
				{
					printf("%s %d\n", item->first.c_str(), item->second);
					flag++;
				}
			}
			if (flag == 0)
				printf("NA\n");
		}
		else if (a == 2)
		{
			int sum = 0, cnt = 0, flag = 0;
			for (item = arr.begin(); item != arr.end(); item++)
			{
				string temp = item->first.substr(1, 3);      //获取准考证的考场号
				if (temp == s)
				{
					cnt++;
					sum += item->second;  
					flag++;
				}
			}
			if (flag != 0)
				printf("%d %d\n", cnt, sum);
			else
				printf("NA\n");
		}
		else if (a == 3)
		{
			int flag = 0;
			unordered_map<string, int> date;    //相同出生日期人的考场号和人数  
			vector<pair<string, int> > three;
			for (item = arr.begin(); item != arr.end(); item++)
			{
				int cnt = 0;
				string temp = item->first.substr(4, 6);    //获取准考证中的出生日期
				if (temp == s)
				{
					string temp2 = item->first.substr(1, 3);   //获取准考证的考场号
					date[temp2] ++;         
					flag++;
				}
			}
			if (flag != 0)
			{
				for (unordered_map<string, int>::iterator it = date.begin(); it != date.end(); it++)
					three.push_back(make_pair(it->first, it->second));    //存入vector数组中排序
				sort(three.begin(), three.end(), compare);
				for (vector<pair<string, int> >::iterator it = three.begin(); it != three.end(); it++)
					printf("%s %d\n", it->first.c_str(), it->second);
			}
			else
				printf("NA\n");
		}
		count++;
	}
	return 0;
}

如果对你有帮助,高抬贵手点个赞吧!

感谢阅读!

如有错误,恳请指正!

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

电影中的梦

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值