I - Enlarge it HDU - 6519

Taotao is glad to see that lots of students have registered for today's algorithm competition. Thus he wants to pull a banner on the wall. But Taotao is so stupid that he doesn't even know how to enlarge words to fit the size of banner. So Taotao gives you a slogan template and asked you to enlarge them in k times.

Input

There are multiple test cases.
For each test case, first line contains three numbers n, m, k (1<=n, m<=100,1<=k<=10).
The next n lines each contain m visible characters.

Output

For each test case, you should output k*n lines each contain k*m visible characters to represent the expanded slogan.

Sample Input

3 3 2
.*.
.*.
.*.

Sample Output

..**..
..**..
..**..
..**..
..**..
..**..
#include <bits/stdc++.h>

using namespace std;
char s[105][105];
int main()
{
    int m,n,i,j,k;
    while(cin>>m>>n>>k)
    {for(i=1;i<=m;i++)
        cin>>s[i];
    for(i=1;i<=m;i++)
        for(int x=1;x<=k;x++)
        {for(j=0;j<n;j++)
            for(int y=1;y<=k;y++)
            cout<<s[i][j];
            cout<<endl;}
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值