寒假集训_专题三题解_A - Cow Contest

题目

N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2

题目大意

给定n头牛,每头牛有一个1到n的值,且任意两头牛的值不同,若知道m个牛的值的次序,问有多少头牛的值可以确定

题解

若st[i][j]为0表示i,j关系不确定,为1表示第i头牛的值大于第j头,为-1表示小于第j头牛,则第i头牛的值能确定的条件为对于每个k≠i,st[i][k]≠0.

代码

#include <iostream>
#include <cstring>
using namespace std;
const int N = 110, M = 4510;
int  st[N][N];
 int main()
 {
 	memset(st,0,sizeof st);
 	int n,m;
 	cin >> n >> m;
 	for(int i = 1; i <= m; i ++)
 	{
 		int u, v;
 		cin >> u >> v;
 		st[u][v] = 1;
 		st[v][u] = -1;
 		for(int j = 1; j <= n; j ++)
 		{
		 	if(st[v][j]==1)
			{
			 	st[u][j] = 1;
			 	st[j][u] = -1;
			}
		 	if(st[u][j] == -1)
			{
			 	st[j][v] = 1;
			 	st[v][j] = -1;
			}
		}
	}
	for(int i = 1; i <= n; i ++)
	for(int j = 1; j <= n; j ++)
		if(st[i][j] == 0)
		for(int k = 1; k <= n; k ++)//通过k能够把i、j关系确定
		{
			if(st[i][k] == 1 && st[k][j] == 1)
			st[i][j] = 1,st[j][i] = -1;
			if(st[j][k] == 1 && st[k][i] == 1)
			st[j][i] =1,st[i][j] = -1;
		}
	int ans = 0;
	for(int i = 1; i <= n; i ++)
	{
		bool flag = true;
		for(int j = 1; j <= n; j++)
			if(st[i][j]==0&&i!=j)flag = false;
		if(flag)ans++;	
	}
	cout << ans;
	return 0;
 }

注意点

1.通过k能够把i、j关系确定

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值