HDU-1247 Hat’s Words 字典树

题目

A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.

Output

Your output should contain all the hat’s words, one per line, in alphabetical order.

Sample Input

a
ahat
hat
hatword
hziee
word

Sample Output

ahat
hatword

解析

题意是找出所有输入单词中可以由另外任意两个输入单词组成的单词(我第一次看题误解成了找出所有带hat的单词233),所以解法即是把所有单词录入字典树后,依次检查是否可以由另外两个字典树中的单词组成。
就像普通的字典树的search函数那样,对每个单词,我们先从头到尾依次检索。但当我们发现在这个单词中间可以作为一个结束点时,我们再将后面的部分独立出来在字典树中查询。
由此我们写出find函数

bool find(char *w) {
    int len = strlen(w);
    int p = 0;
    for (int i = 0; i < len;i++){
        int c = w[i] - 'a';
        p = trie[p][c];
        if(trie_end[p]) if(trie_search(&w[i+1])) return true;
    }
    return false;
}

答案

#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <list>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cctype>
using namespace std;

const int TRIE_MAX = 1000000;//最大节点数
const int CHARSET = 26;//字符集
int trie[TRIE_MAX][CHARSET] = {0};//字典树
int trie_end[TRIE_MAX] = {0};//记录结束点
int trie_k = 1;//已有节点数

char s[50003][53] = {0};

void trie_insert(char *w){
    int len = strlen(w);
    int p = 0;
    for (int i = 0; i < len;i++){
        int c = w[i] - 'a';
        if(!trie[p][c]){
            trie[p][c] = trie_k++;
        }
        p = trie[p][c];
    }
    trie_end[p] = 1;
}

bool trie_search(char *w){
    int len = strlen(w);
    int p = 0;
    for (int i = 0; i < len;i++){
        int c = w[i] - 'a';
        if(!trie[p][c]) return false;
        p = trie[p][c];
    }
    return trie_end[p] == 1;
}

bool find(char *w) {
    int len = strlen(w);
    int p = 0;
    for (int i = 0; i < len;i++){
        int c = w[i] - 'a';
        p = trie[p][c];
        if(trie_end[p]) if(trie_search(&w[i+1])) return true;
    }
    return false;
}

int main(){
    int ans = 0;
    while(~scanf("%s", s[ans])){
        trie_insert(s[ans]);
        ans++;
    }
    for (int i = 0; i < ans;i++){
        if(find(s[i])){
            printf("%s\n", s[i]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值