7-5 单词首字母大写 (15分)

本题目要求编写程序,输入一行字符,将每个单词的首字母改为大写后输出。所谓“单词”是指连续不含空格的字符串,各单词之间用空格分隔,空格数可以是多个。
输入格式:

输入给出一行字符。
输出格式:

在一行中输出已输入的字符,其中所有单词的首字母已改为大写。
输入样例:

How are you?

输出样例:

How Are You?

#include <stdio.h>
#include <stdlib.h>

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main(int argc, char *argv[]) {

   char a[10000];
   gets(a);
   int i=0;
   int count=0;
   int flag=0;
   for(i=0;i<strlen(a);i++){	  
   	  if(a[i]!=32){
   	  	 count++;   //记录一个单词由多少个字母组成
   	  }
	  else
	  {
	  	   if(count!=0)	
		    {	  
		        //将首个字母转换成大写  	
				if(a[i-count]>='a'&&a[i-count]<='z') a[i-count]-= 32;
			  	count=0;
	  	    }
	  }   	 	  
   }
   if(count>0) {    //最后一个单词
   	  if(a[i-count]>='a'&&a[i-count]<='z') a[i-count]-= 32;
   } 
   for(i=0;i<strlen(a);i++){
   		printf("%c",a[i]);
   } 
	return 0;
}
  • 18
    点赞
  • 47
    收藏
    觉得还不错? 一键收藏
  • 16
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 16
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值