7-81 Least Prefix (10分)

Given a non-empty array of N integers A, please find the smallest integer P such that all the numbers in A are in the subarray A[0…P].

Input Format:

A positive number N, followed by a list of N non-negative integers less than 1000000. N is no larger than 1000000.

Output Format:

The smallest integer P.

Sample Input:

5
2 2 1 0 1

Sample Output:

3

我的代码:

/**帽***/ 
#include <stdio.h>
int  main(){    
	int a[1000000]={0},i,n,k;    
	scanf("%d",&n);    
	int index=0;    
	for(i=0;i<n;i++){        
		scanf("%d",&k);        
		if(a[k]==0){            
			a[k]=1;            
			index=i;        
		}       
	}    
	printf("%d",index);        
	return 0;
}

我知道很简单,但我花了好多时间才读懂题,岂可修!!!
顺便这是我自己用来测试的一个例子:
10 5 2 0 3 5 4 7 8 9 6

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 5
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值