最小字符串

【问题描述】

给定一些字符串(只包含小写字母),要求将他们串起来构成一个字典序最小的字符串。

【输入格式】

第一行T,表示有T组数据。
接下来T组数据
每组第一行一个正整数n,表示字符串个数。
接下来n行,每行一个字符串(长度不超过100)。

【输出格式】

T行,每行一个字符串。

【样例输入】

1
3
a
b
c

【样例输出】

abc

【参考代码】

#include <bits/stdc++.h>

using namespace std;

bool cmp(string const s1, string const s2) {
    return s1 + s2 < s2 + s1;
}

int main() {
    ios::sync_with_stdio(false);
    int t;
    cin >> t;
    while (t--) {
        vector<string> vec;
        int n;
        cin >> n;
        while (n--) {
            string temp;
            cin >> temp;
            vec.push_back(temp);
        }
        sort(vec.begin(), vec.end(), cmp);
        for (vector<string>::iterator it = vec.begin(); it != vec.end(); it++) {
            cout << *it;
        }
        cout << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

上山打老虎D

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值