1001. A+B Format (20) [字符串处理]

1001. A+B Format (20) [字符串处理]
Calculate a + b and output the sum in standard format — that is, the digits must be separated into groups
of three by commas (unless there are less than four digits).


Input
Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a,
b <= 1000000. The numbers are separated by a space.


Output
For each test case, you should output the sum of a and b in one line. The sum must be written in the
standard format.


Sample Input
-1000000 9


Sample Output
-999,991
题⽬⼤意:计算A+B的和,然后以每三位加⼀个”.”的格式输出

 

解:用to_string转化为字符串s,这题就很简单了,然后就是:如果和是整数,那么(i+1)%3==0,输出","就可以了,但和也有可能是负      数,就需要考虑别的算式;

综上,不管和是正还是负,直接用 (i+1)%3 == len%3,  len是s的长度。

#include <iostream>
#include <string>
using namespace std;

int main() {
	int a, b;
	cin >> a >> b;
	string s = to_string(a + b);
	int len = s.length();
	for (int i = 0; i < len; i++) {
		cout << s[i];
		if (s[i] == '-') continue;
		if ((i + 1) % 3 == len % 3 && i != len - 1) cout << ",";
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值