1019 数字黑洞 (20 分)

给定任一个各位数字不完全相同的 4 位正整数,如果我们先把 4 个数字按非递增排序,再按非递减排序,然后用第 1 个数字减第 2 个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的 6174,这个神奇的数字也叫 Kaprekar 常数。

例如,我们从6767开始,将得到

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

现给定任意 4 位正整数,请编写程序演示到达黑洞的过程。

输入格式:
输入给出一个 (0,104) 区间内的正整数 N。

输出格式:
如果 N 的 4 位数字全相等,则在一行内输出 N - N = 0000;否则将计算的每一步在一行内输出,直到 6174 作为差出现,输出格式见样例。注意每个数字按 4 位数格式输出。
输入样例 1:

6767

输出样例 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

代码如下:

#include<iostream>
#include <queue>
#include<string>
#include<vector>
#include<map>
#include<algorithm>
#include<math.h>
#include <iomanip> 
#include <algorithm>
#pragma warning(disable:4996)
using namespace std;
string biaozhun(int a)
{
	string s;
	if (a == 0)
		s = "0000";
	else if (a > 0 && a < 10)
	{
		s = "000";
		s = s + char(a + '0');
	}
	else if (a >= 10 && a < 100)
	{
		s = "00";
		s = s + char(a / 10 + '0');
		s = s + char(a % 10 + '0');
	}
	else if (a >= 100 && a < 1000)
	{
		s = "0";
		s = s + char(a / 100 + '0');
		s = s + char((a / 10) % 10 + '0');
		s = s + char(a % 10 + '0');
	}
	else {
		s = "";
		s = s + char(a / 1000 + '0');
		s = s + char((a / 100) % 10 + '0');
		s = s + char((a / 10) % 10 + '0');
		s = s + char(a % 10 + '0');
	}
	return s;
}
int nixu(int a)
{
	vector<int> shuru;
	string s = biaozhun(a);
	for (auto i = 0; i < s.size(); i++)
	{
		shuru.push_back(int(s[i]) - '0');
	}
	sort(shuru.begin(), shuru.end());
	int res = 0;
	int count = 1;
	for (auto i = shuru.rbegin();i != shuru.rend();i++)
	{
		res += *i * count;
		count *= 10;
	}
	return res;
}
int zhengxu(int a)
{
	vector<int> shuru;
	string s = biaozhun(a);
	for (auto i = 0; i <s.size(); i++)
	{
		shuru.push_back(int(s[i])-'0');
	}
	sort(shuru.begin(), shuru.end());
	int res = 0;
	int count = 1;
	for (auto i = shuru.begin();i != shuru.end();i++)
	{
		res += *i * count;
		count *= 10;
	}
	return res;
}
void fun(int a)
{
	int zhengx =zhengxu(a);
	int nix = nixu(a);
	cout << biaozhun(zhengx) << " - " << biaozhun(nix) << " = " << biaozhun(zhengx - nix)<< endl;
	if (zhengx - nix == 0 || zhengx - nix == 6174|| zhengx - nix==a)
		return;
	else
		fun(zhengx - nix);
}
int main()
{
    int a;
	cin >> a;
	fun(a);

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值