Cow Hurdles

Cow Hurdles

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 50 Accepted Submission(s) : 35
Problem Description

题目描述
Farmer John wants the cows to prepare for the county jumping competition, so Bessie and the gang are practicing jumping over hurdles. They are getting tired, though, so they want to be able to use as little energy as possible to jump over the hurdles.

Obviously, it is not very difficult for a cow to jump over several very short hurdles, but one tall hurdle can be very stressful. Thus, the cows are only concerned about the height of the tallest hurdle they have to jump over.

The cows’ practice room has N (1 ≤ N ≤ 300) stations, conveniently labeled 1…N. A set of M (1 ≤ M ≤ 25,000) one-way paths connects pairs of stations; the paths are also conveniently labeled 1…M. Path i travels from station Si to station Ei and contains exactly one hurdle of height Hi (1 ≤ Hi ≤ 1,000,000). Cows must jump hurdles in any path they traverse.

The cows have T (1 ≤ T ≤ 40,000) tasks to complete. Task i comprises two distinct numbers, Ai and Bi (1 ≤ Ai ≤ N; 1 ≤ Bi ≤ N), which connote that a cow has to travel from station Ai to station Bi (by traversing over one or more paths over some route). The cows want to take a path the minimizes the height of the tallest hurdle they jump over when traveling from Ai to Bi . Your job is to write a program that determines the path whose tallest hurdle is smallest and report that height.

输入描述
Input

  • Line 1: Three space-separated integers: N, M, and T
  • Lines 2…M+1: Line i+1 contains three space-separated integers: Si , Ei , and Hi
  • Lines M+2…M+T+1: Line i+M+1 contains two space-separated integers that describe task i: Ai and Bi

输出描述
Output

  • Lines 1…T: Line i contains the result for task i and tells the smallest possible maximum height necessary to travel between the stations. Output -1 if it is impossible to travel between the two stations.

样例
Sample Input

5 6 3 1 2 12 3 2 8 1 3 5 2 5 3 3 4 4 2 4 8 3 4 1 2 5 1

Sample Output

4 8 -1

题意:已知有n个木桩,以及其中m对木桩的高度差,共执行t次跳跃任务,每次求从木桩u跳到木桩v,最少的跳跃高度,如果无法到达,输出-1。

思路:题目求的是每条路径所经过的相邻的木桩差值的最大值,然后取所有路径跳跃高度的最小值,因为只有找出相邻差值的最大值,其他的高度均可以跳跃。用 Floyd 算法跑一遍,关键在于当不同类 g[i][k] 和 g[k][j] 合并时,求从i到j内的最大值;当同类两个 g[i][j] 选最优值时,求从i到j所有值的最小值。

代码

#include<iostream>
#include<cstdio>
#include<cmath>
#include<iomanip>
#include<cstdlib>
#define INF 0x3f3f3f//定义无穷大
using namespace std;
int mp[1050][1050];//定义相邻高度差
void floyd(int n)
{
    for(int k=1;k<=n;k++)
    for(int i=1;i<=n;i++)
     for(int j=1;j<=n;j++)
     if(mp[i][k]<mp[i][j]&&mp[k][j]<mp[i][j]){
        mp[i][j]=max(mp[i][k],mp[k][j]);}//更新
     }
int main()
{

    int n,m,t;
    while(~scanf("%d%d%d",&n,&m,&t)){
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                if(i==j){
                    mp[i][j]=0;
                }
                else {
                    mp[i][j]=INF;
                }
            }
        }int u,v,h;
        for(int i=1;i<=m;i++)
        {

            scanf("%d%d%d",&u,&v,&h);
            mp[u][v]=h;
        }
        floyd(n);
        for(int i=1;i<=t;i++)
        {
            scanf("%d%d",&u,&v);
            if(mp[u][v]==INF)
            {

                printf("-1\n");}
                else {
                    printf("%d\n",mp[u][v]);
                }
            }
        }return 0;
    }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

稚皓君

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值