Find The Multiple POJ - 1426

Find The Multiple POJ - 1426

Given a positive integer n, write a program to find out a nonzero
multiple m of n whose decimal representation contains only the digits
0 and 1. You may assume that n is not greater than 200 and there is a
corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

题意

给定一个正整数n,请编写一个程序来寻找n的一个非零的倍数m,这个m应当在十进制表示时每一位上只包含0或者1。你可以假定n不大于200且m不多于100位。
提示:本题采用Special Judge,你无需输出所有符合条件的m,你只需要输出任一符合条件的m即可。

Input

输入包含多组数据,每组数据仅一行,只包含一个正整数n (1 <= n <= 200).

Output

对于输入的每组n,都输出任一符合条件的m。即使有多个符合条件的m,你也只需要输出一个即可。

方法一dfs

所求得的数只含有1或0,所以从1开始深搜,两个方向(n * 10) 或者(n * 10+1)。dfs终止条件:找到那个数或者这个数的长度大于19。 至于为何要大于19,很简单**,long long最大值就是19位**

#include<iostream>
using namespace std;
typedef long long ll;
ll n;
bool dfs(ll ans,ll step)
{
    if(step>19)return false;
    if(ans%n==0)
    {
        cout<<ans<<endl;
        return true;
    }
    if(dfs(ans*10+1,step+1))
        return true;
    if(dfs(ans*10,step+1))
        return true;
}
int main()
{
    while(cin>>n&&n!=0)
    {
        dfs(1,1);
    }
}

方法二:bfs
(交代码选G++,选C++可能会超时)

#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
typedef long long ll;
int n;
int bfs()
{
    queue<ll>q;
    q.push(1);//从1开始广搜
    while(!q.empty())
    {
        ll t=q.front();
        q.pop();
        ll x=t*10;
        ll y=x+1;
        if(t%n==0)
        {
            cout<<t<<endl;
            break;
        }
        q.push(x);
        q.push(y);

    }
}
int main()
{
    while(cin>>n&&n!=0)
    {
        bfs();
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

稚皓君

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值