高精度问题整合

ACM竞赛知识整合篇

因为刚入门没多久(菜的真实),acm省赛也进在眼前,在这一个月内把自己这入门两个月左右的知识整理一下,也算给自己的暑假一个交代。这个是C++的高精度问题整合JAVA的请出门左转,用BigInteger

高精度加减法

加法(Integer Inquiry HDU - 1047)

加法就是将,数一位一位存起来,然后位位相加发生进位的位置保留与10取膜的结果,高位加上低位与10相除的结果。减法与加法类似,不足就向前借位低位+10高位-1。

//a存输入的数(低位先存,高位在尾),sum是存的当前输入数的总和
vector<int> add(vector<int> &a,vector<int> &sum)
{
   
    int t=0;
    vector<int> ans;
    for(int i=0;i<a.size()||i<sum.size();i++){
   //位位相加
        if(i<a.size()) t+=a[i];
        if(i<sum.size()) t+=sum[i];
        ans.push_back(t%10);
        t/=10;//保留相加后的进位结果
    }
    if(t) ans.push_back(t);//若最后t不为0,加入最高位
    while(ans.size()>1&&ans.back()==0) ans.pop_back();//去除前导0
    return ans;//返回结果
}

题目地址传送

Integer Inquiry
Problem Description

One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
This supercomputer is great,'' remarked Chip.I only wish Timothy were here to see these results.’’ (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).
The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.

Sample Input

1
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

CODE

#include <iostream>
#include <string>
#include <cstring>
#include <vector>
using namespace std;
vector<int> add(vector<int> &a,vector<int> &sum)
{
   
    int t=0;
    vector<int> ans;
    for(int i=0;i<a.size()||i<sum.size();i++){
   //高精度加法
        if(i<a.size()) t+=a[i];
        if(i<sum.size()) t+=sum[i];
        ans.push_back(t%10);
        t/=10;
    }
    if(t) ans.push_back(t);//若最后t不为0,加入最高位
    while(ans.size()>1&&ans.back()==0) ans.pop_back();
    return ans;
}
int main()
{
   
    int n;
    string a;
    vector<int> sum,b;
    cin>>n;
    while(n--){
   
        bool flag=true;
        while(cin>>a&&a>"0"){
   //循环加法
            for(int i=a.size()-1;i>=0;i--)//反向存入
                b.push_back(a[i]-'0');
            sum=add(b,sum);
            b.clear();
            flag=false;
        }
        if(flag){
   
            cout<<"0";
            flag=true;
        }
        for(int i=sum.size()-1;i
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值