OSPF综合项目 2021-09-21

OSPF综合项目
image.png

实验作业:

\1. 要求依据综合拓扑配置直连连通性;

按上图在gns3上搭建环境

[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-0GIGWUK3-1632234454274)(/Users/aron/Pictures/20210921.png)]

配置IP地址
R2#conf t  
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int s2/0
R2(config-if)#ip add 24.1.1.24 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int s2/1
R2(config-if)#ip add 23.1.1.23 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int e0/0
R2(config-if)#ip add 10.1.1.2 255.255.255.0 
R2(config-if)#no shutdown
R2(config-if)#end

R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#int s2/0
R4(config-if)#ip add 24.1.1.42 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#int s2/3
R4(config-if)#ip add 45.1.1.45 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#int e0/1
R4(config-if)#ip add 10.1.1.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#end

R1(vlan167)
R1(config)#int e0/3
R1(config-if)#no shutdown
R1(config-if)#ip add 167.1.1.13 255.255.255.0
R1(config-if)#end

R6(vlan167)
R6#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R6(config)#int e1/0
R6(config-if)#no sh
R6(config-if)#ip add 167.1.1.60 255.255.255.0
R6(config-if)#end

R7(vlan167)
R7#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R7(config)#int e0/2
R7(config-if)#no sh
R7(config-if)#ip add 167.1.1.72 255.255.255.0
R7(config-if)#end

R8(vlan167)
R8#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R8(config)#int e1/2
R8(config-if)#no sh 
R8(config-if)#ip add 167.1.1.82 255.255.255.0
R8(config-if)#end

SW4(vlan167)
SW4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
SW4(config)#no ip routing
SW4(config)#exit

SW4#vlan database
SW4(vlan)#vlan 167
VLAN 167 added:
    Name: VLAN0167
SW4(vlan)#exit
APPLY completed.
Exiting....
SW4#conf t
SW4(config)#no ip routing
Enter configuration commands, one per line.  End with CNTL/Z.
SW4(config)#int range f0/0 - 3        
SW4(config-if-range)#switchport mode access    
SW4(config-if-range)#switchport access vlan 167
SW4(config-if-range)#end
SW4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
SW4(config)#no spanning-tree vlan 167
SW4(config)#no cdp run


R6(vlan168)
R6#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R6(config)#int e1/1
R6(config-if)#no sh
R6(config-if)#ip add 168.1.1.61 255.255.255.0
R6(config-if)#exit
R6(config)#int s2/0
R6(config-if)#no sh
R6(config-if)#ip add 106.1.1.62 255.255.255.0
R6(config-if)#end

R8(vlan168)
R8#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R8(config)#int e1/3
R8(config-if)#no sh
R8(config-if)#ip add 168.1.1.83 255.255.255.0
R8(config-if)#exit
R8(config)#int s2/1
R8(config-if)#no sh 
R8(config-if)#ip add 108.1.1.81 255.255.255.0
R8(config-if)#end

R10(vlan168)
R10#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R10(config)#int e0/0
R10(config-if)#no sh
R10(config-if)#ip add 168.1.1.100 255.255.255.0
R10(config-if)#exit
R10(config)#int s2/0
R10(config-if)#ip add 106.1.1.100 255.255.255.0
R10(config-if)#no sh
R10(config-if)#exit
R10(config)#int s2/1
R10(config-if)#no sh
R10(config-if)#ip add 108.1.1.101 255.255.255.0
R10(config-if)#end

SW4(vlan168)
SW4#vlan database
SW4(vlan)#vlan 168
VLAN 168 added:
    Name: VLAN0168
SW4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
SW4(config)#int range f0/4 - 6
SW4(config-if-range)#switchport mode access 
SW4(config-if-range)#switchport access vlan 168
SW4(config-if-range)#shutdown
SW4(config-if-range)#no sh
SW4(config-if-range)#
其他同理,并测试联通性!


[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-Fd9ivIRz-1632234454275)(/Users/aron/Library/Application Support/typora-user-images/image-20210905102513363.png)]


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#no ip do lo
R2(config)#lin console 0
R2(config-line)#logging synchronous
R2(config-line)#exec-time 0 0
R2(config-line)#exit
R2(config)#username Pinging secret cisco
R2(config)#lin console 0
R2(config-line)#login local
R2(config-line)#exit
R2(config)#lin vty 0 15
R2(config-line)#login local
R2(config-line)#exit
R2(config)#enable secret CISCO
R2(config)#exit
R2#show run

R1-R10,SW1-SW4同理

 

SW1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
SW1(config)#int range f0/0 - 3
SW1(config-if-range)#no shutdown
SW1(config-if-range)#end
*Mar  1 00:09:55.271: %SYS-5-CONFIG_I: Configured from console by console
SW1#show  ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  up                    up      
FastEthernet0/1            unassigned      YES unset  up                    up      
FastEthernet0/2            unassigned      YES unset  up                    up      
FastEthernet0/3            unassigned      YES unset  up                    up    

其他同理

\2. 要求根据OSPF区域设计将OSPF运行在相应区域中;

R1#conf t
R1(config)#router ospf 90
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 15.1.1.0 0.0.0.255 area 157
R1(config-router)#network 17.1.1.0 0.0.0.255 area 157
R1(config-router)#network 136.1.1.0 0.0.0.255 area 136
R1(config-router)#end
R1#

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router ospf 90
R2(config-router)#router-id 2.2.2.2 
R2(config-router)#network 24.1.1.0 0.0.0.255 area 0
R2(config-router)#network 23.1.1.0 0.0.0.255 area 0
R2(config-router)#network 10.1.1.0 0.0.0.255 area 0
R2(config-router)#end
R2#

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router ospf 90
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 23.1.1.0 0.0.0.255 area 0
R3(config-router)#network 35.1.1.0 0.0.0.255 area 0
R3(config-router)#network 10.1.1.0 0.0.0.255 area 0
R3(config-router)#network 136.1.1.0 0.0.0.255 area 136
R3(config-router)#end

R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#router ospf 90
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 24.1.1.0 0.0.0.255 area 0
R4(config-router)#network 45.1.1.0 0.0.0.255 area 0
R4(config-router)#network 10.1.1.0 0.0.0.255 area 0
R4(config-router)#end


R5#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R5(config)#router ospf 90
R5(config-router)#router-id 5.5.5.5
R5(config-router)#network 45.1.1.0 0.0.0.255 area 0
R5(config-router)#network 35.1.1.0 0.0.0.255 area 0
R5(config-router)#network 10.1.1.0 0.0.0.255 area 0
R5(config-router)#network 15.1.1.0 0.0.0.255 area 157
R5(config-router)#network 57.1.1.0 0.0.0.255 area 157
R5(config-router)#end


R6#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R6(config)#router ospf 90
R6(config-router)#router-id 6.6.6.6
R6(config-router)#network 136.1.1.0 0.0.0.255 area 136
R6(config-router)#end

R7#conf t 
Enter configuration commands, one per line.  End with CNTL/Z.
R7(config)#router ospf 90
R7(config-router)#router-id 7.7.7.7
R7(config-router)#network 57.1.1.0 0.0.0.255 area 157
R7(config-router)#network 17.1.1.0 0.0.0.255 area 189
R7(config-router)#network 189.1.1.0 0.0.0.255 area 189
R7(config-router)#end
R7#

R8#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R8(config)#router ospf 90
R8(config-router)#router-id 8.8.8.8
R8(config-router)#network 189.1.1.0 0.0.0.255 area 189
R8(config-router)#end

R9#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R9(config)#router ospf 90
R9(config-router)#router-id 9.9.9.9
R9(config-router)#network 189.1.1.0 0.0.0.255 area 189
R9(config-router)#end


\3. 要求将RIPv2和EIGRP运行在OSPF外部网络中;

R1(RIPv2)
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary 
R1(config-router)#network 167.1.1.0
R1(config-router)#end

R6(RIPv2)
R6#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R6(config)#router rip
R6(config-router)#no auto-summary 
R6(config-router)#version 2
R6(config-router)#network 167.1.1.0
R6(config-router)#end

R7(RIPv2)#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R7(config)#router rip
R7(config-router)#version 2
R7(config-router)#no atu
R7(config-router)#no aut
R7(config-router)#no auto-summary 
R7(config-router)#ne
R7(config-router)#netw
R7(config-router)#network 167.1.1.0


R8(RIPv2)#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R8(config)#router rip
R8(config-router)#version 2
R8(config-router)#no atuo
R8(config-router)#no auto
R8(config-router)#no auto-summary 
R8(config-router)#networ
R8(config-router)#network 167.1.1.0
R8(config-router)#end


R6(eigrp)
R6#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R6(config)#router eigrp 168
R6(config-router)#no aut
R6(config-router)#no auto-summary 
R6(config-router)#network 168.1.1.0 0.0.0.255
R6(config-router)#net
R6(config-router)#network 106.1.1.0 0.0.0.255
R6(config-router)#end

R8(eigrp)#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R8(config)#router eigrp 168
R8(config-router)#no auto-summary 
R8(config-router)#network 168.1.1.0 0.0.0.255
R8(config-router)#network 108.1.1.0 0.0.0.255
R8(config-router)#end

R10(eigrp)#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R10(config)#router eigrp 168
R10(config-router)#no auto-summary 
R10(config-router)#network 168.1.1.0 0.0.0.255
R10(config-router)#network 106.1.1.0 0.0.0.255
R10(config-router)#network 108.1.1.0 0.0.0.255
R10(config-router)#end



\4. 要求在AREA 0上面通过wireshark将点对点链路和以太网链路的邻居过程抓包,并进行对比;

[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-RYbgQCko-1632234454277)(/Users/aron/Pictures/image-20210921220439332.png)]

[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-O1ENhHOO-1632234454278)(/Users/aron/Pictures/image-20210921220456363.png)]

\5. 要求将脱节区域“挂到”骨干区域,可通过虚链路来实现;

R5#config 
Configuring from terminal, memory, or network [terminal]? t
Enter configuration commands, one per line.  End with CNTL/Z.
R5(config)#router ospf 90
R5(config-router)#area 157 virtual-link 7.7.7.7
R5(config-router)#

R7#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R7(config)#router ospf 90
R7(config-router)#area 157 virtual-link 5.5.5.5
R7(config-router)#

R7#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
5.5.5.5           0   INIT/  -        00:00:38    57.1.1.50       OSPF_VL0
5.5.5.5           1   FULL/BDR        00:00:38    57.1.1.50       Ethernet0/0
1.1.1.1           1   FULL/BDR        00:00:38    17.1.1.11       Ethernet1/1
8.8.8.8           1   FULL/DROTHER    00:00:39    189.1.1.80      Ethernet0/1
9.9.9.9           1   FULL/DR         00:00:39    189.1.1.92      Ethernet0/1


R5#show ip ospf neigh

Neighbor ID     Pri   State           Dead Time   Address         Interface
4.4.4.4           0   FULL/  -        00:00:33    45.1.1.45       Serial2/3
3.3.3.3           0   FULL/  -        00:00:33    35.1.1.35       Serial2/2
2.2.2.2           1   2WAY/DROTHER    00:00:32    10.1.1.2        Ethernet0/2
3.3.3.3           1   FULL/BDR        00:00:33    10.1.1.3        Ethernet0/2
4.4.4.4           1   FULL/DR         00:00:33    10.1.1.4        Ethernet0/2
7.7.7.7           1   FULL/DR         00:00:34    57.1.1.70       Ethernet0/0
1.1.1.1           1   FULL/BDR        00:00:34    15.1.1.11       Ethernet0/1
R5#


\6. 要求在R2/R3/R4/R5上分别建立环回接口Loopback100,并要求IP地址为:

174.17.0.1/24

174.17.1.1/24

174.17.2.1/24

174.17.3.1/24

之后要求在R3和R5上做区域间汇总,并观察其cost值;

(1)要求在R2/R3/R4/R5上分别建立环回接口Loopback100,并配置IP地址

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int lo 100
R2(config-if)#aip
*Mar  1 00:12:34.579: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback100, changed state to up
R2(config-if)#ip add 174.17.0.1 255.255.255.0
R2(config-if)#exit  
R2(config)#router ospf 90
R2(config-router)#network 174.17.0.0 0.0.0.255 area 0
R2(config-router)#end

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#int lo100
R3(config-if)#ip
*Mar  1 00:13:18.775: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback100, changed state to up
R3(config-if)#ip add 174.17.1.1 255.255.255.0
R3(config-if)#router ospf 90
R3(config-router)#networ
R3(config-router)#network 
R3(config-router)#network 174.17.1.0 0.0.0.255 area 0
R3(config-router)#end


R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#int lo100
R4(config-if)#ip 
*Mar  1 00:14:48.807: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback100, changed state to up
R4(config-if)#ip add 174.17.2.1 255.255.255.0
R4(config-if)#router ospf 90
R4(config-router)#network 174.17.2.0 0.0.0.255 area 0
R4(config-router)#end

R5#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R5(config)#int lo100
R5(config-if)#ip add 
*Mar  1 00:15:07.503: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback100, changed state to up
R5(config-if)#ip add 174.17.3.1 255.255.255.0
R5(config-if)#router ospf 90
R5(config-router)#network 174.17.3.0 0.0.0.255 area 0
R5(config-router)#end
R5#

(2)R3和R5上做区域间汇总,并观察其cost值
R3和R5做区域汇总:
R3:
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router ospf 90
R3(config-router)#area 0 range 174.17.0.0 255.255.252.0
R5:
R5#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R5(config)#router ospf 90
R5(config-router)#area 0 range 174.17.0.0 255.255.252.0
在 R1 上查看路由
R1#show ip route ospf
     35.0.0.0/24 is subnetted, 1 subnets
O IA    35.1.1.0 [110/74] via 136.1.1.30, 00:14:14, Ethernet0/2
                 [110/74] via 15.1.1.51, 00:14:14, Ethernet0/1
     174.17.0.0/16 is variably subnetted, 5 subnets, 2 masks
O IA    174.17.2.1/32 [110/21] via 15.1.1.51, 00:01:18, Ethernet0/1
O IA    174.17.3.1/32 [110/11] via 15.1.1.51, 00:01:18, Ethernet0/1
O IA    174.17.0.1/32 [110/21] via 15.1.1.51, 00:01:18, Ethernet0/1
O IA    174.17.1.1/32 [110/21] via 15.1.1.51, 00:01:18, Ethernet0/1
O IA    174.17.0.0/22 [110/11] via 136.1.1.30, 00:01:18, Ethernet0/2
     23.0.0.0/24 is subnetted, 1 subnets
O IA    23.1.1.0 [110/74] via 136.1.1.30, 00:14:14, Ethernet0/2
     189.1.0.0/24 is subnetted, 1 subnets
O IA    189.1.1.0 [110/20] via 17.1.1.71, 00:14:04, Ethernet1/1
     24.0.0.0/24 is subnetted, 1 subnets
O IA    24.1.1.0 [110/84] via 136.1.1.30, 00:14:14, Ethernet0/2
                 [110/84] via 15.1.1.51, 00:14:14, Ethernet0/1
     57.0.0.0/24 is subnetted, 1 subnets
O       57.1.1.0 [110/20] via 17.1.1.71, 00:14:15, Ethernet1/1
                 [110/20] via 15.1.1.51, 00:14:15, Ethernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
O IA    10.1.1.0 [110/20] via 136.1.1.30, 00:14:15, Ethernet0/2
                 [110/20] via 15.1.1.51, 00:14:15, Ethernet0/1
     45.0.0.0/24 is subnetted, 1 subnets
O IA    45.1.1.0 [110/74] via 15.1.1.51, 00:14:16, Ethernet0/1
可以看到汇总后的 cost 为 11,
R1#show ip ospf database summary 174.17.0.0

            OSPF Router with ID (1.1.1.1) (Process ID 90)

                Summary Net Link States (Area 136)

  Routing Bit Set on this LSA
  LS age: 116
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 174.17.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000001
  Checksum: 0x7EF4
  Length: 28
  Network Mask: /22
        TOS: 0  Metric: 1 



查询验证
R2#show ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
4.4.4.4           0   FULL/  -        00:00:35    24.1.1.42       Serial2/0
3.3.3.3           0   FULL/  -        00:00:34    23.1.1.32       Serial2/1
3.3.3.3           1   FULL/BDR        00:00:34    10.1.1.3        Ethernet0/0
4.4.4.4           1   FULL/DR         00:00:34    10.1.1.4        Ethernet0/0
5.5.5.5           1   2WAY/DROTHER    00:00:34    10.1.1.5        Ethernet0/0
R2#
R2#
R2#show run | sec r ospf
router ospf 90
 router-id 2.2.2.2
 log-adjacency-changes
 network 10.1.1.0 0.0.0.255 area 0
 network 23.1.1.0 0.0.0.255 area 0
 network 24.1.1.0 0.0.0.255 area 0
 network 174.17.0.0 0.0.0.255 area 0
R2#
R3#show ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
5.5.5.5           0   FULL/  -        00:00:35    35.1.1.53       Serial2/2
2.2.2.2           0   FULL/  -        00:00:34    23.1.1.23       Serial2/1
2.2.2.2           1   FULL/DROTHER    00:00:34    10.1.1.2        Ethernet0/3
4.4.4.4           1   FULL/DR         00:00:34    10.1.1.4        Ethernet0/3
5.5.5.5           1   FULL/DROTHER    00:00:35    10.1.1.5        Ethernet0/3
1.1.1.1           1   FULL/DROTHER    00:00:39    136.1.1.12      Ethernet0/0
6.6.6.6           1   FULL/DR         00:00:39    136.1.1.63      Ethernet0/0
R3#
R3#
R3#show run | sec r ospf
router ospf 90
 router-id 3.3.3.3
 log-adjacency-changes
 network 10.1.1.0 0.0.0.255 area 0
 network 23.1.1.0 0.0.0.255 area 0
 network 35.1.1.0 0.0.0.255 area 0
 network 136.1.1.0 0.0.0.255 area 136
 network 174.17.1.0 0.0.0.255 area 0
R3#

R4#show ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
5.5.5.5           0   FULL/  -        00:00:34    45.1.1.54       Serial2/3
2.2.2.2           0   FULL/  -        00:00:33    24.1.1.24       Serial2/0
2.2.2.2           1   FULL/DROTHER    00:00:34    10.1.1.2        Ethernet0/1
3.3.3.3           1   FULL/BDR        00:00:34    10.1.1.3        Ethernet0/1
5.5.5.5           1   FULL/DROTHER    00:00:34    10.1.1.5        Ethernet0/1
R4#
R4#
R4#show run | sec r ospf
router ospf 90
 router-id 4.4.4.4
 log-adjacency-changes
 network 10.1.1.0 0.0.0.255 area 0
 network 24.1.1.0 0.0.0.255 area 0
 network 45.1.1.0 0.0.0.255 area 0
 network 174.17.2.0 0.0.0.255 area 0
R4#

R5#show ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
7.7.7.7           0   FULL/  -           -        57.1.1.70       OSPF_VL0
4.4.4.4           0   FULL/  -        00:00:34    45.1.1.45       Serial2/3
3.3.3.3           0   FULL/  -        00:00:34    35.1.1.35       Serial2/2
2.2.2.2           1   2WAY/DROTHER    00:00:33    10.1.1.2        Ethernet0/2
3.3.3.3           1   FULL/BDR        00:00:34    10.1.1.3        Ethernet0/2
4.4.4.4           1   FULL/DR         00:00:34    10.1.1.4        Ethernet0/2
7.7.7.7           1   FULL/DR         00:00:38    57.1.1.70       Ethernet0/0
1.1.1.1           1   FULL/BDR        00:00:38    15.1.1.11       Ethernet0/1
R5#
R5#
R5#show run | sec r ospf
router ospf 90
 router-id 5.5.5.5
 log-adjacency-changes
 area 157 virtual-link 7.7.7.7
 network 10.1.1.0 0.0.0.255 area 0
 network 15.1.1.0 0.0.0.255 area 157
 network 35.1.1.0 0.0.0.255 area 0
 network 45.1.1.0 0.0.0.255 area 0
 network 57.1.1.0 0.0.0.255 area 157
 network 174.17.3.0 0.0.0.255 area 0
R5#


\7. 在RIP域中,建立Looback100,并要求通过从地址设置四个网段为

==> 173.17.0.1/24

173.17.1.1/24

173.17.2.1/24

173.17.3.1/24

要求在R1和R7上做路由重分布,并通过AS间路由汇总,将外部网段聚合;在R1上的重分布要求用E1类型并指定metric为100;在R7上的重分布要求用默认类型E2并指定metric为1

(验证OSPF路由选举: O > O IA > O E1 > O E2)

R8 建立 Looback100
R8#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R8(config)#int lo 100
R8(config-if)#ip add 173.17.0.1 255.255.255.0
R8(config-if)#ip add 173.17.1.1 255.255.255.0 secondary 
R8(config-if)#ip add 173.17.2.1 255.255.255.0 secondary 
R8(config-if)#ip add 173.17.3.1 255.255.255.0 secondary 
R8(config)#router rip 
R8(config-router)#network 173.17.0.0 


在R1上重分布
R1(config)#router ospf 100
R1(config-router)#redistribute rip subnets metric-type 1 metric 100
R1(config-router)#summary-address 173.17.0.0 255.255.255.0
R1(config-router)#end
使用opsf100不管用,使用ospf90 反而能重发布
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router ospf 90
R1(config-router)# summary-address 173.17.0.0 255.255.252.0
R1(config-router)# redistribute rip metric 100 metric-type 1 subnets
R1(config-router)#end


在R7上重发布
R7#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R7(config)#router ospf 100
R7(config-router)#redistribute rip subnets metric-type 2 metric 1
R7(config-router)#summary-address 173.17.0.0 255.255.252.0

从R5上查看重发布情况:
R5#show ip route ospf
     17.0.0.0/24 is subnetted, 1 subnets
O       17.1.1.0 [110/20] via 57.1.1.70, 00:00:07, Ethernet0/0
                 [110/20] via 15.1.1.11, 00:00:07, Ethernet0/1
     136.1.0.0/24 is subnetted, 1 subnets
O IA    136.1.1.0 [110/20] via 10.1.1.3, 00:00:07, Ethernet0/2
     100.0.0.0/22 is subnetted, 1 subnets
O E1    100.100.0.0 [110/30] via 10.1.1.3, 00:00:07, Ethernet0/2
     168.1.0.0/24 is subnetted, 1 subnets
O E1    168.1.1.0 [110/30] via 10.1.1.3, 00:00:07, Ethernet0/2
     174.17.0.0/16 is variably subnetted, 5 subnets, 3 masks
O       174.17.2.1/32 [110/11] via 10.1.1.4, 18:39:50, Ethernet0/2
O       174.17.0.1/32 [110/11] via 10.1.1.2, 18:39:50, Ethernet0/2
O       174.17.1.1/32 [110/11] via 10.1.1.3, 18:39:50, Ethernet0/2
O       174.17.0.0/22 is a summary, 18:39:50, Null0
     23.0.0.0/24 is subnetted, 1 subnets
O       23.1.1.0 [110/74] via 10.1.1.3, 18:39:50, Ethernet0/2
                 [110/74] via 10.1.1.2, 18:39:50, Ethernet0/2
     189.1.0.0/24 is subnetted, 1 subnets
O IA    189.1.1.0 [110/20] via 57.1.1.70, 00:00:08, Ethernet0/0
     173.17.0.0/22 is subnetted, 1 subnets
O E1    173.17.0.0 [110/110] via 15.1.1.11, 00:00:09, Ethernet0/1
     24.0.0.0/24 is subnetted, 1 subnets
O       24.1.1.0 [110/74] via 10.1.1.4, 18:39:51, Ethernet0/2
                 [110/74] via 10.1.1.2, 18:39:51, Ethernet0/2
     108.0.0.0/24 is subnetted, 1 subnets
O E1    108.1.1.0 [110/30] via 10.1.1.3, 00:00:01, Ethernet0/2
     106.0.0.0/24 is subnetted, 1 subnets
O E1    106.1.1.0 [110/30] via 10.1.1.3, 00:00:02, Ethernet0/2
     167.1.0.0/24 is subnetted, 1 subnets
O E1    167.1.1.0 [110/110] via 15.1.1.11, 00:00:02, Ethernet0/1

在R9上查看重发布情况:
R9#show ip route ospf
     17.0.0.0/24 is subnetted, 1 subnets
O IA    17.1.1.0 [110/20] via 189.1.1.71, 00:00:07, Ethernet0/2
     136.1.0.0/24 is subnetted, 1 subnets
O IA    136.1.1.0 [110/40] via 189.1.1.71, 00:00:07, Ethernet0/2
     35.0.0.0/24 is subnetted, 1 subnets
O IA    35.1.1.0 [110/84] via 189.1.1.71, 00:00:07, Ethernet0/2
     100.0.0.0/22 is subnetted, 1 subnets
O E1    100.100.0.0 [110/50] via 189.1.1.71, 00:00:07, Ethernet0/2
     168.1.0.0/24 is subnetted, 1 subnets
O E1    168.1.1.0 [110/50] via 189.1.1.71, 00:00:07, Ethernet0/2
     174.17.0.0/32 is subnetted, 4 subnets
O IA    174.17.2.1 [110/31] via 189.1.1.71, 00:00:07, Ethernet0/2
O IA    174.17.3.1 [110/21] via 189.1.1.71, 00:00:07, Ethernet0/2
O IA    174.17.0.1 [110/31] via 189.1.1.71, 00:00:07, Ethernet0/2
O IA    174.17.1.1 [110/31] via 189.1.1.71, 00:00:07, Ethernet0/2
     23.0.0.0/24 is subnetted, 1 subnets
O IA    23.1.1.0 [110/94] via 189.1.1.71, 00:00:07, Ethernet0/2
     173.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    173.17.0.0/24 [110/1] via 189.1.1.71, 00:00:03, Ethernet0/2
O E2    173.17.0.0/22 [110/1] via 189.1.1.71, 00:00:03, Ethernet0/2
     24.0.0.0/24 is subnetted, 1 subnets
O IA    24.1.1.0 [110/94] via 189.1.1.71, 00:00:08, Ethernet0/2
     57.0.0.0/24 is subnetted, 1 subnets
O IA    57.1.1.0 [110/20] via 189.1.1.71, 00:00:10, Ethernet0/2
     10.0.0.0/24 is subnetted, 1 subnets
O IA    10.1.1.0 [110/30] via 189.1.1.71, 00:00:10, Ethernet0/2
     108.0.0.0/24 is subnetted, 1 subnets
O E1    108.1.1.0 [110/50] via 189.1.1.71, 00:00:10, Ethernet0/2
     106.0.0.0/24 is subnetted, 1 subnets
O E1    106.1.1.0 [110/50] via 189.1.1.71, 00:00:11, Ethernet0/2
     167.1.0.0/24 is subnetted, 1 subnets
O E1    167.1.1.0 [110/120] via 189.1.1.71, 00:00:11, Ethernet0/2
     45.0.0.0/24 is subnetted, 1 subnets
O IA    45.1.1.0 [110/84] via 189.1.1.71, 00:00:12, Ethernet0/2
     15.0.0.0/24 is subnetted, 1 subnets
O IA    15.1.1.0 [110/30] via 189.1.1.71, 00:00:13, Ethernet0/2
R9#
R9#

\8. 在EIGRP中配置路由认证,要求key-id为1,key string cisco,key chain为CISCO;在R10上建立环回接口,网段为:

100.100.1.0/24

100.100.2.0/24

100.100.3.0/24;

并在R10的接口上进行汇总;

EIGRP中配置路由认证,要求key-id为1,key string cisco,key chain为CISCO:
R6:
R6#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R6(config)#key chain cisco
R6(config-keychain)#key 1
R6(config-keychain-key)#key-string CISCO
R6(config-keychain-key)#int e1/1
R6(config-if)#ip authentication mode eigrp 168 md5
R6(config-if)#ip authentication key-chain eigrp 168 cisco
R6(config-if)#int s2/0
R6(config-if)#ip authentication mode eigrp 168 md5
R6(config-if)#ip authentication key-chain eigrp 168 cisco

R8:
R8#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R8(config)#key chain cisco
R8(config-keychain)#key 1
R8(config-keychain-key)#key-string CISCO
R8(config-keychain-key)#int e1/3
R8(config-if)#ip authentication mode eigrp 168 md5
R8(config-if)#ip authentication key-chain eigrp 168 cisco
R8(config-if)#int s2/1
R8(config-if)#ip authentication mode eigrp 168 md5
R8(config-if)#ip authentication key-chain eigrp 168 cisco


R10#conf t    
Enter configuration commands, one per line.  End with CNTL/Z.
R10(config)#key chain cisco
R10(config-keychain)#key 1
R10(config-keychain-key)#key-string CISCO
R10(config-keychain-key)#int e0/0
R10(config-if)#ip authentication mode eigrp 168 md5
R10(config-if)#ip authentication key-chain eigrp 168 cisco
R10(config-if)#int s2/1
R10(config-if)#ip authentication mode eigrp 168 md5
R10(config-if)#ip authentication key-chain eigrp 168 cisco
R10(config-if)#int s2/0
R10(config-if)#ip authentication mode eigrp 168 md5
R10(config-if)#ip authentication key-chain eigrp 168 cisco

查看邻居是否建立:

R10上建立回环接口,并汇总:
R10(config-if)#int lo100
R10(config-if)#ip add 100.100.1.1 255.255.255.0
R10(config-if)#ip add 100.100.2.1 255.255.255.0 secondary 
R10(config-if)#ip add 100.100.3.1 255.255.255.0 secondary 
R10(config-if)#router eigrp 168
R10(config-router)#network 100.100.0.0 0.0.255.255
R10(config-router)#int e0/0
R10(config-if)#ip summary-address eigrp 168 100.100.0.0 255.255.252.0
R10(config-if)#int s2/0
R10(config-if)#ip summary-address eigrp 168 100.100.0.0 255.255.252.0
R10(config-if)#int s2/1
R10(config-if)#ip summary-address eigrp 168 100.100.0.0 255.255.252.0
R10(config-if)#

在R6上查看:

R6#show ip route eigrp
     100.0.0.0/22 is subnetted, 1 subnets
D       100.100.0.0 [90/409600] via 168.1.1.100, 00:01:11, Ethernet1/1
     108.0.0.0/24 is subnetted, 1 subnets
D       108.1.1.0 [90/2195456] via 168.1.1.100, 00:03:32, Ethernet1/1
                  [90/2195456] via 168.1.1.83, 00:03:32, Ethernet1/1
R6#

在R8上查看:
R8#show ip route eigrp
     100.0.0.0/22 is subnetted, 1 subnets
D       100.100.0.0 [90/409600] via 168.1.1.100, 00:04:53, Ethernet1/3
     106.0.0.0/24 is subnetted, 1 subnets
D       106.1.1.0 [90/2195456] via 168.1.1.100, 00:07:42, Ethernet1/3
                  [90/2195456] via 168.1.1.61, 00:07:42, Ethernet1/3
                  

\9. 要求在R6上执行路由重分布并将EIGRP域的路由信息导入OSPF,修改外部路由类型为E1,metric为10;

R6#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R6(config)#router ospf 90
R6(config-router)#redistribute eigrp 168 subnets metric-type 1 metric 10


R3#show ip route ospf
     17.0.0.0/24 is subnetted, 1 subnets
O IA    17.1.1.0 [110/30] via 10.1.1.5, 00:00:04, Ethernet0/3
     100.0.0.0/22 is subnetted, 1 subnets
O E1    100.100.0.0 [110/20] via 136.1.1.63, 00:00:04, Ethernet0/0
     168.1.0.0/24 is subnetted, 1 subnets
O E1    168.1.1.0 [110/20] via 136.1.1.63, 00:00:04, Ethernet0/0
     174.17.0.0/16 is variably subnetted, 5 subnets, 3 masks
O       174.17.2.1/32 [110/11] via 10.1.1.4, 18:34:40, Ethernet0/3
O       174.17.3.1/32 [110/11] via 10.1.1.5, 18:34:40, Ethernet0/3
O       174.17.0.1/32 [110/11] via 10.1.1.2, 18:34:40, Ethernet0/3
O       174.17.0.0/22 is a summary, 18:34:40, Null0
     189.1.0.0/24 is subnetted, 1 subnets
O IA    189.1.1.0 [110/30] via 10.1.1.5, 00:00:04, Ethernet0/3
     24.0.0.0/24 is subnetted, 1 subnets
O       24.1.1.0 [110/74] via 10.1.1.4, 18:34:40, Ethernet0/3
                 [110/74] via 10.1.1.2, 18:34:40, Ethernet0/3
     57.0.0.0/24 is subnetted, 1 subnets
O IA    57.1.1.0 [110/20] via 10.1.1.5, 00:00:04, Ethernet0/3
     108.0.0.0/24 is subnetted, 1 subnets
O E1    108.1.1.0 [110/20] via 136.1.1.63, 00:00:05, Ethernet0/0
     106.0.0.0/24 is subnetted, 1 subnets
O E1    106.1.1.0 [110/20] via 136.1.1.63, 00:00:05, Ethernet0/0
     45.0.0.0/24 is subnetted, 1 subnets
O       45.1.1.0 [110/74] via 10.1.1.5, 18:34:42, Ethernet0/3
                 [110/74] via 10.1.1.4, 18:34:42, Ethernet0/3
     15.0.0.0/24 is subnetted, 1 subnets
O IA    15.1.1.0 [110/20] via 10.1.1.5, 00:00:07, Ethernet0/3

从 EIGRP 学习到的外部路由类型为 E1,metric 为 10,加上链路 cost 10,总共 20

\10. 在骨干区域中执行OSPF区域内认证,要求通过MD5认证,key-id为1,密文cisco;在AREA 157上执行OSPF链路间认证,要求采用MD5认证;通过key id 为15 17 57,密文对应为15 17 57进行认证;

在骨干区域中执行OSPF区域内认证,要求通过MD5认证,key-id为1,密文cisco:
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router ospf 90
R2(config-router)#area 0 authentication message-digest 
R2(config-router)#int s2/0        
R2(config-if)#ip ospf message-digest-key 1 md5 cisco
R2(config-if)#int s2/1
R2(config-if)#ip ospf message-digest-key 1 md5 cisco
R2(config-if)#int e0/0
R2(config-if)#ip ospf message-digest-key 1 md5 cisco


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router ospf 90
R3(config-router)#area 0 authentication message-digest 
R3(config-router)#int s2/1
R3(config-if)#ip ospf message-digest-key 1 md5 cisco
R3(config-if)#int s2/3
R3(config-if)#ip ospf message-digest-key 1 md5 cisco
R3(config-if)#int e0/1
R3(config-if)#ip ospf message-digest-key 1 md5 cisco


R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#router ospf 90
R4(config-router)#area 0 authentication message-digest 
R4(config-router)#int s2/0
R4(config-if)#ip ospf message-digest-key 1 md5 cisco
R4(config-if)#int s2/3
R4(config-if)#ip ospf message-digest-key 1 md5 cisco
R4(config-if)#int e0/1
R4(config-if)#ip ospf message-digest-key 1 md5 cisco

R5#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R5(config)#router ospf 90
R5(config-router)#area 0 authentication message-digest 
R5(config-router)#int s2/2
R5(config-if)#ip ospf message-digest-key 1 md5 cisco
R5(config-if)#int s2/3
R5(config-if)#ip ospf message-digest-key 1 md5 cisco
R5(config-if)#int e0/2
R5(config-if)#ip ospf message-digest-key 1 md5 cisco

在AREA 157上执行OSPF链路间认证,要求采用MD5认证;通过key id 为15 17 57,密文对应为15 17 57进行认证
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int e0/1
R1(config-if)#ip ospf authentication message-digest 
R1(config-if)#ip ospf message-digest-key 15 md5 15
R1(config-if)#int e1/1
R1(config-if)#ip ospf authentication message-digest 
R1(config-if)#ip ospf message-digest-key 17 md5 17

R5#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R5(config)#int e0/0
R5(config-if)#ip ospf authentication message-digest 
R5(config-if)#ip ospf message-digest-key 57 md5 57
R5(config-if)#int e0/1
R5(config-if)#ip ospf authentication message-digest         
R5(config-if)#ip ospf message-digest-key 15 md5 15
R5(config-if)#


R7#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R7(config)#int e0/0 
R7(config-if)#ip ospf authentication message-digest 
R7(config-if)#ip ospf message-digest-key 57 md5 57
R7(config-if)#int e1/1
R7(config-if)#ip ospf authentication message-digest 
R7(config-if)#ip ospf message-digest-key 17 md5 17
R7(config-if)#


R5和R7虚链路认证:
R5(config)#router ospf 90
R5(config-router)#area 157 virtual-link 7.7.7.7 message-digest-key 57 md5 57
R5(config-router)#area 157 virtual-link 7.7.7.7 authentication message-digest

R7(config)#router ospf 90
R7(config-router)#area 157 virtual-link 5.5.5.5 message-digest-key 57 md5 57
R7(config-router)#area 157 virtual-link 5.5.5.5 authentication message-digest
R7(config-router)#
*Mar  1 00:22:31.091: %OSPF-5-ADJCHG: Process 90, Nbr 5.5.5.5 on OSPF_VL0 from LOADING to FULL, Loading Done
R7(config-router)#


\11. 在区域189中,R9上通告默认路由,并建立环回接口99.99.99.99/32,要求其他区域的所有路由器能够ping通;R8上建立环回接口loopback100,地址为88.88.88.88/32,将此环回接口设为被动;

区域189中,R9上通告默认路由,并建立环回接口99.99.99.99/32,要求其他区域的所有路由器能够ping通
R9#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R9(config)#int lo1
*Mar  1 00:05:55.667: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R9(config-if)#ip add 99.99.99.99 255.255.255.255
R9(config-if)#router ospf 90
R9(config-router)#default-information originate always 
R9(config-router)#

R1#ping 99.99.99.99

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 99.99.99.99, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/18/20 ms
R1#

R8上建立环回接口loopback100,地址为88.88.88.88/32,将此环回接口设为被动
R8#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R8(config)#int lo1 
*Mar  1 00:07:23.167: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R8(config-if)#ip add 88.88.88.88 255.255.255.255
R8(config-if)#router ospf 90
R8(config-router)#network 88.88.88.88 0.0.0.0 area 189
R8(config-router)#passive-interface lo1
R8(config-router)#


\12. 在区域136中,将此区域设置为NSSA,要求在重分布时通过抓包获取7类LSA;

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router ospf 90
R1(config-router)#area 136 nssa
R1(config-router)#

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router ospf 90
R3(config-router)#area 136 nssa
R3(config-router)#

R6#
R6#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R6(config)#router ospf 90
R6(config-router)#area 136 nssa
R6(config-router)#



                Router Link States (Area 136)
          
Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         36          0x80000005 0x006AF2 2
3.3.3.3         3.3.3.3         37          0x80000007 0x00A382 2
6.6.6.6         6.6.6.6         36          0x80000004 0x001C3F 1
          
                Net Link States (Area 136)
          
Link ID         ADV Router      Age         Seq#       Checksum
136.1.1.30      3.3.3.3         57          0x80000001 0x00501F
136.1.1.63      6.6.6.6         37          0x80000005 0x00D74A
          
                Summary Net Link States (Area 136)
          
Link ID         ADV Router      Age         Seq#       Checksum
10.1.1.0        3.3.3.3         67          0x80000004 0x009978
15.1.1.0        3.3.3.3         68          0x80000002 0x00C044
17.1.1.0        3.3.3.3         68          0x80000002 0x000BED
23.1.1.0        3.3.3.3         69          0x80000002 0x0012BE
24.1.1.0        3.3.3.3         69          0x80000002 0x00695C
35.1.1.0        3.3.3.3         69          0x80000002 0x00754F
45.1.1.0        3.3.3.3         69          0x80000002 0x005759
57.1.1.0        3.3.3.3         69          0x80000002 0x009C3E
88.88.88.88     3.3.3.3         69          0x80000002 0x002A7F
174.17.0.0      3.3.3.3         70          0x80000002 0x00224A
189.1.1.0       3.3.3.3         70          0x80000002 0x004606
          
                Type-7 AS External Link States (Area 136)
          
Link ID         ADV Router      Age         Seq#       Checksum Tag
100.100.0.0     6.6.6.6         44          0x80000001 0x004633 0
106.1.1.0       6.6.6.6         45          0x80000001 0x00A42E 0
108.1.1.0       6.6.6.6         45          0x80000001 0x008A46 0
167.1.1.0       1.1.1.1         101         0x80000001 0x005238 0
168.1.1.0       6.6.6.6         46          0x80000001 0x007B19 0
173.17.0.0      1.1.1.1         102         0x80000001 0x003F39 0
          
                Type-5 AS External Link States
          
Link ID         ADV Router      Age         Seq#       Checksum Tag
0.0.0.0         9.9.9.9         336         0x80000001 0x0074C0 90
100.100.0.0     3.3.3.3         38          0x80000001 0x00355A 0
106.1.1.0       3.3.3.3         38          0x80000001 0x009355 0
108.1.1.0       3.3.3.3         38          0x80000001 0x00796D 0
167.1.1.0       1.1.1.1         74          0x80000002 0x00CC55 0
167.1.1.0       7.7.7.7         716         0x80000001 0x00BB32 0
168.1.1.0       3.3.3.3         39          0x80000001 0x006A40 0
173.17.0.0      1.1.1.1         74          0x80000002 0x00B956 0
173.17.0.0      7.7.7.7         604         0x80000001 0x00A833 0


\13. 将区域189设置为STUB区域,在R7上通过no-summary参数将此区域变成Totally STUB区域;

13. 将区域189设置为STUB区域,在R7上通过no-summary参数将此区域变成Totally STUB区域
R7#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R7(config)#router ospf 90
R7(config-router)#area 189 stub no-summary 

R8#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R8(config)#router ospf 90
R8(config-router)#area 189 stub
R8(config-router)#
*Mar  1 00:14:11.231: %OSPF-5-ADJCHG: Process 90, Nbr 7.7.7.7 on Ethernet0/0 from FULL to DOWN, Neighbor Down: Dead timer expired
R8(config-router)#
*Mar  1 00:14:13.079: %OSPF-5-ADJCHG: Process 90, Nbr 9.9.9.9 on Ethernet0/0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
R8(config-router)#



R9#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R9(config)#router ospf 90
R9(config-router)#area 189 stub no-summary
Warning: Router is currently an ASBR while having only one area which is a stub area
R9(config-router)#
*Mar  1 00:14:51.399: %OSPF-5-ADJCHG: Process 90, Nbr 8.8.8.8 on Ethernet0/2 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
R9(config-router)#
*Mar  1 00:15:00.919: %OSPF-5-ADJCHG: Process 90, Nbr 8.8.8.8 on Ethernet0/2 from LOADING to FULL, Loading Done
*Mar  1 00:15:01.019: %OSPF-5-ADJCHG: Process 90, Nbr 7.7.7.7 on Ethernet0/2 from LOADING to FULL, Loading Done
R9(config-router)#end



R9#show ip route ospf
     88.0.0.0/32 is subnetted, 1 subnets
O       88.88.88.88 [110/11] via 189.1.1.80, 00:00:20, Ethernet0/2
O*IA 0.0.0.0/0 [110/11] via 189.1.1.71, 00:00:20, Ethernet0/2
R9#

\14. 在骨干区域中,让 R5 退出 DR/BDR 选举,并要求让 R2 成为 DR, R3 成为 BDR,其他为 DRother

在骨干区域中,让 R5 退出 DR/BDR 选举,并要求让 R2 成为 DR, R3 成为 BDR,其他为 DRother
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#
R2(config)#int e0/0
R2(config-if)#ip ospf priority 10
R2(config-if)#
*Mar  1 21:16:47.894: %OSPF-5-ADJCHG: Process 90, Nbr 3.3.3.3 on Ethernet0/0 from LOADING to FULL, Loading Done
*Mar  1 21:16:47.894: %OSPF-5-ADJCHG: Process 90, Nbr 5.5.5.5 on Ethernet0/0 from LOADING to FULL, Loading Done
R2(config-if)#

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#int e0/3
R3(config-if)#ip ospf priority 5
R3(config-if)#
*Mar  1 21:16:47.886: %OSPF-5-ADJCHG: Process 90, Nbr 2.2.2.2 on Ethernet0/3 from LOADING to FULL, Loading Done
R3(config-if)#

R5#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R5(config)#int e0/2
R5(config-if)#ip ospf priori
R5(config-if)#ip ospf priority 0
R5(config-if)#



R5#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
4.4.4.4           0   FULL/  -        00:00:36    45.1.1.45       Serial2/3
3.3.3.3           0   FULL/  -        00:00:34    35.1.1.35       Serial2/2
2.2.2.2          10   FULL/BDR        00:00:35    10.1.1.2        Ethernet0/2
3.3.3.3           5   2WAY/DROTHER    00:00:34    10.1.1.3        Ethernet0/2
4.4.4.4           1   FULL/DR         00:00:36    10.1.1.4        Ethernet0/2
7.7.7.7           0   FULL/  -           -        57.1.1.70       OSPF_VL0
7.7.7.7           1   FULL/DR         00:00:36    57.1.1.70       Ethernet0/0
1.1.1.1           1   FULL/BDR        00:00:34    15.1.1.11       Ethernet0/1
R5#

----

【作业要求】
1、用GNS3搭建拓扑,并根据要求完成项目;
2、将整个GNS3项目文件打包为压缩包,并以附件上传,压缩包的名称规范为“姓名-OSPF综合实验”。

  • 1
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值