1002-Fire Net-C语言

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.
1002-Fire Net

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.’ indicating an open space and an uppercase ‘X’ indicating a wall. There are no spaces in the input file.

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:

5
1
5
2
4

#include<stdio.h>
//	使用一维数组构建city布局 
static char city[16];
//	amount为最多堡垒数目,n为city宽度 
static unsigned int amount, n;

int main(){
	unsigned int i;
	void dfs(unsigned int index, unsigned int count);
	scanf("%u", &n);
	while(n != 0){
        amount = 0;
//      读取city布局
		for(i = 0; i < n; i++) scanf("%s", &city[i*n]);
//      使用dfs函数,从city[0][0]开始搜索
		dfs(0,0);
        printf("%u\n",amount);
		scanf("%u", &n);
	}
	return 0;
}
//  index表示city中的位置,count记录堡垒个数
void dfs(unsigned int index, unsigned int count){
    int noBlockhouse(unsigned int index);
//  搜索到最后一个字符时,返回上一级
    if(index  == n * n){
        if(count > amount) amount = count;
        count = 0;
        return;
    };
//  判断是否可以放置堡垒
    if(city[index] == '.' && noBlockhouse(index)){
//      可以放置则标记为堡垒,并继续深度搜索
        city[index] = 'b';
        dfs(index + 1, count + 1);
//      搜索结束返回上一级,并清除堡垒标记,寻找同一层级其他情况
        city[index] = '.';
    }
        dfs(index + 1, count);
}
//  判断横纵是否有堡垒
int noBlockhouse(unsigned int index){
    //	从一维数组中抽象出行与列
    unsigned int row = index / n;
    unsigned int column = index % n;
//  不可更换while循环顺序,因为第一个循环需要使用row的初始值
    while(index >= row*n && city[index] != 'X' ){
        if(city[index] == 'b') return 0;
//      防止index变为负数
        if(index == 0) break;
        index --;
    }
    while(row >= 0 && city[row*n+column] != 'X'){
    	if(city[row*n+column] == 'b') return 0;
    	if(row == 0) break;
    	row --;
	}
    return 1;
}

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

零一魔法

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值