04-树6 Complete Binary Search Tree (30 分) (完全二叉树的特性,二叉搜索树的特性,顺序表存储二叉树,等等)

这道题目要求将给定的有序整数序列构造成一个完全二叉搜索树,并输出层次遍历序列。首先对输入数据进行排序,然后通过完全二叉树的性质确定根节点并进行分治,递归地处理左右子树,最终得到层次遍历序列。通过顺序表存储二叉树,可以方便地输出层次遍历结果。示例输入10个整数,输出的层次遍历序列为6 3 8 1 5 7 9 0 2 4。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
结尾无空行
Sample Output:
6 3 8 1 5 7 9 0 2 4

这题的大概意思是所以二叉搜索树都可以编程完全二叉树形式的二叉搜索树,要我们层次遍历的方式输出该完全二叉搜索树。
1.显然这道题我们把完全二叉搜索树存储在顺序表里面合适,因为顺序表直接输出的结果就是二叉树层次遍历输出的结果
2.首先要利用sort函数把输入结点数据从小到大排序
3.然后根据完全二叉树的性质,设置一个函数找到根节点对应的排序数组的那个数据值。因为二叉搜索树左边一定比根节点小,右边一定比根结点大,所以可以用根节点对应的数据值把大树分成两颗子树,先把这颗大树根结点的值存储到顺序表第一个位置里面,然后找到子树根节点对应的顺序表位置,然后再分别递归。找顺序标对应头结点位置的方法和堆相似,左节点为2*root+1,右节点为左节点加一。
根据下图即可明显看出
在这里插入图片描述
每一个节点的数组下标值与它头上的节点的下标值都是有关联的,这样计算便简单了。
下面为代码:

#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
const int MaxSize = 10001;
int First[MaxSize] = { 0 }, Last[MaxSize] = { 0 };
//这里N为完全二叉树的结点个数,这个函数根据结点个数输出左子树的结点个数
int getleft(int N)
{
	int H = log(N + 1) / log(2);//判断完整的层数为多少
	int left = pow(2, H - 1) - 1;//先把完整部分初始化给left
	int X = N - pow(2, H) + 1;
	int Y = pow(2, H - 1);
	X = min(X,Y);//得到左子树剩余部分的结点树
	left += X;//得到真正的左子树结点个数
	return left;
}
//把从小到大排序的数组递归存储在二叉树顺序存储数组里面,因为二叉树顺序存储数组按照
//层次遍历方式依次存储,所以最后直接输出就可以了。
//存储数组第一个a[0]为根节点,a[1],a[2]分别为第二次从左到右依次过去
//a[3],a[4],a[5],a[6]分别为第三层依次过去........
void digui(int left0, int right0, int Root)
{
	int number = right0 - left0 + 1;
	if (number == 0)return;//这个少了的话递归结束不了,会出现堆栈溢出等段错误;
	int left = getleft(number);
	Last[Root] = First[left0+left];//把完全二叉树根节点存储在第一个位置,Root初始为0
	//****这里特别注意First里面是Left+left0,因为left代表该部分的左边结点个数,加上left0才是对应
	//****的数组下标
	int Rootleft = Root * 2 + 1;//Rootleft表示Root的左节点,在数组里面为第二个位置,下标为1
	int Rootright= Rootleft + 1;//Rootright因为相邻,直接加一即可
	//Rootleft,Rootright分别表示原来Root结点的左右子树的头结点,在下面两个左右子树递归里面
	//分布是两部分树递归的头结点
	digui(left0, left0 + left - 1, Rootleft);
	digui(left0 + left + 1, right0, Rootright);
}
int main()
{
	int N;
	cin >> N;
	for (int i = 0;i < N;++i)
		cin >> First[i];
	sort(First, First + N);
	digui(0, N - 1, 0);
	for (int i = 0;i < N-1;++i)
		cout << Last[i] << " ";
	cout << Last[N - 1];
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值