2021-09-29

破案问题
在这里插入图片描述

样例输入
3 2
166 50 30
178 60 23
132 40 15
167 50 30
178 60 23

样例输出
no
yes

#include<iostream>
#include<set>
using namespace std;
struct people{
	int h;
	int w;
	int age;
	people(int h1,int w1,int age1){
		h=h1;
		w=w1;
		age=age1;
	}
	bool operator<(const people &rsh) const{
	    if(h!=rsh.h){
	   	return h<rsh.h;
	   }
	    if(w!=rsh.w){
	   	return w<rsh.w;
	   }
	   return age<rsh.age;
	   
	}
};
set<people> s;
int main()
{
	int h,w,age,n,m;
	cin>>n>>m;
	for(int i=0;i<n;i++){
		cin>>h>>w>>age;
		s.insert(people(h,w,age));
	}
	for(int i=0;i<m;i++){
		cin>>h>>w>>age;
		if(s.count(people(h,w,age))){
			cout<<"yes"<<endl;
		}else{
			cout<<"no"<<endl;
		}
	} 
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值