PTA:7-4 解密英文藏头诗 (15分)

PTA:7-4 解密英文藏头诗 (15分)
本题要求编写一个解密英文藏头诗的程序。建议使用动态内存分配方法处理字符串的输入。

输入格式:
输入为一首英文藏头诗,每句一行,小于20行,每行不超过80个字符,以#作为藏头诗的输入结束标志。

输出格式:
取出每句的第一个字符,连接在一起形成一个字符串并输出。

输入样例:
I come into a dream
Leaves fall down but spring
over a lake birds flying
village have its nice morning
everywhere can feel happiness
Years have never been
owners don’t need anything
until the sun bring another wind

输出样例:
ILoveYou

#include<stdio.h>
#include<stdlib.h>
int main()
{
int i, n = 0;
char *s[100], str[100];

char e;
scanf("%c",&e);
while(e!='\n')
{
if(e!=' ')
{

str[i]=e;
i++;
}
scanf("%c",&e);
}
i=0;
while(str[0] != '#')
{
    s[n] = (char *) malloc( sizeof(char) * ( strlen(str) + 1 ));
    strcpy(s[n], str);
    n++;
    scanf("%c",&e);
while(e!='\n')
{
if(e!=' ')
{
str[i]=e;
i++;
}
scanf("%c",&e);
}
    i=0;
}
for(int i =0; i < n; i++)
{   char ss[110];
    strcpy(ss, s[i]);
    printf("%c", ss[0]);
    free(s[i]);
}
//system("pause");
return 0;

}

  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值