寻找大富翁

序言
此篇博客作为自己的学习笔记,同时欢迎大家交流!

题目

浙江桐乡乌镇共有n个人,请找出该镇上的前m个大富翁.

Input

输入包含多组测试用例.
每个用例首先包含2个整数n(0<n<=100000)和m(0<m<=10),其中: n为镇上的人数,m为需要找出的大富翁数, 接下来一行输入镇上n个人的财富值.
n和m同时为0时表示输入结束.

Output

请输出乌镇前m个大富翁的财产数,财产多的排前面,如果大富翁不足m个,则全部输出,每组输出占一行.

Sample Input

3 1
2 5 -1
5 3
1 2 3 4 5
0 0

Sample Output

5
5 4 3

//C++STL优先队列
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue> 

using namespace std;

int main()
{
	priority_queue<int>q;//优先队列,类似于队列,但会自动排序
	int n,m,x;
	while(scanf("%d%d",&n,&m),n||m)//n和m同时为0,输入结束
	{
		while(!q.empty()) q.pop();//清空队列
		for(int i=0;i<n;i++)
		{
			scanf("%d",&x);
			q.push(x);
		}
		for(int i=1;i<m;i++)
		{
		  printf("%d ",q.top());
          q.pop(); 	
	    }
		printf("%d\n",q.top());
		}
 
	return 0;
}

优先队列和队列基本操作相同:

top 访问队头元素
empty 队列是否为空
size 返回队列内元素个数
push 插入元素到队尾 (并排序)
emplace 原地构造一个元素并插入队列
pop 弹出队头元素
swap 交换内容
//数组 sort排序 自定义排序
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

const int N  =1e5+10;

int q[N];
int n,m;

bool cmp(int a, int b)
{

    return a>b;
}

int main()
{

    while(scanf("%d%d",&n,&m)){
            if(n==0&&m==0) return 0;
    for(int i=0;i<n;i++)scanf("%d",&q[i]);
    sort(q,q+n,cmp);
    for(int i=0;i<m-1;i++)printf("%d ",q[i]);
    printf("%d\n",q[m-1]);
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值