PAT甲级-1042 Shuffling Machine

原题链接如下:
1042 Shuffling Machine

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

题目大意为:

有54张牌,编号为1~54,初始按编号从小到大排列。另外,这些牌按初始排列给定花色,即从左至右分别为 13张S、13张H、13张C、13张D、2张J,如下所示:
S1, S2,…,S13, H1, H2,…, H13, C1, C2,…, C13, D1, D2,…, D13, J1, J2

接下来执行一种操作,这种操作将牌的位置改变为指定位置。例如有5张牌 S3,H5,C1,D13,J2,然后给定操作序列{4,2,5,3,1},因此把 S3放到4 号位、把H5放到2号位、C1放到5号位、D13放到3号位、 J2 放到1号位,于是就变成了J2,H5, D13, S3, C1。
现在需要将这种操作执行K次,求最后的排列结果。例如上面的例子中,如果执行第二
次操作,那么序列 J2,H5,D13, S3, C1 就会变成 C1, H5, S3, 52, D13。

解题思路:

设置两个数组start[]end[],分别用来存放执行操作前的牌序和执行操作后的牌序,即start[i]表示操作前第i个位置的牌的编号。这样在每一次操作中就可以把数组start[]中的每一个位置的牌号存放到数组end[]的对应转换位置中,然后用数组end[]覆盖数组start[]来给下一次操作使用。这样执行完K轮操作后,数组start[]中存放了最终的牌序
由于输出需要用花色来表示,我们用char数组mp来建立编号与花色的关系。char mp[] = {S,H,C,D,J} 例如,假设当前牌号为x,那么mp[(x-1)/13]即为这张牌对应的花色(即1-13号为’S’,14-26号为’H’)

参考代码如下:

#include<stdio.h>
//先定义一个牌的总数,每种花色13张牌,加上大小王,最后一共54张牌
#define N 54
char mp[5]={'S','H','C','D','J'};//牌的编号和花色的对应关系
int start[N+1],end[N+1],next[N+1];//next数组表示题目中输入的第二行,也就是每个位置上的牌在进行一次洗牌操作之后的位置
int main(){
    int K;//洗牌次数
    scanf("%d",&K);
    for(int i=1;i<=N;i++){
        start[i]=i;//初始化一副按顺序的新牌
    }
    //第二行输入 输入每个位置上的牌在操作之后的位置
    for(int i=1;i<=N;i++){
        scanf("%d",&next[i]);
    }
    //开始执行洗牌操作 一共K次
    for(int step=0;step<K;step++){
        for(int i=1;i<=N;i++){
            end[next[i]]=start[i];//核心洗牌操作
        }
        //把end数组赋值给start数组 以便下次使用
        for(int i=1;i<=N;i++){
        start[i] = end[i];
        }
    }
    
    //现在开始输出
    for(int i=1;i<=N;i++){
        if(i!=1)printf(" ");
        printf("%c%d",mp[(start[i]-1)/13],(start[i]-1)%13+1);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值