POJ - 3069 Saruman‘s Army

问题描述:

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

输入说明:

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

输出说明:

For each test case, print a single integer indicating the minimum number of palantirs needed.

SAMPLE INPUT:

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

SAMPLEOUTPUT:

2
4

hintS:

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

思路:

(题目联动魔戒)白袍巫师萨鲁曼带领他的军队行军,军队配备有一种名为帕兰提斯的石头,可以帮助军队不迷路(大概?),这些石头必须由人携带(即不能凭空存在),问最少需要多少石头能够覆盖整支军队。
首先输入石头可以覆盖的范围(这个范围能覆盖石头的前后),以及有多少军队,然后输入所有军队的位置,输入完成后对这些位置进行排序(从小到大),因为石头必须要由军队携带,遍历所有的军队位置(在每一块石头范围的内的都可以不用携带石头)因此从第一支军队的位置开始遍历,找到对于这支军队来说,最右边的,在R范围内的点,并做标记(这支军队携带石头),从被标记点出发,向右R范围内所有军队也都不用携带,标记范围外的第一支军队,从这支军队开始继续重复上述操作,直到遍历了所有的军队。

AC代码:

#include<bits/stdc++.h/**/>
using namespace std;
int main()
{
	int R,n,i,t,p,l=0,sum;
	int a[1005];
	while(scanf("%d%d",&R,&n)&&R!=-1&&n!=-1)
	{
		for(i=0;i<n;i++)
        {
			cin>>a[i];
		}
		sort(a,a+n);
		int l = 0, sum = 0;
		while(l<n)
		{
			t=a[l++];
			while(l<n&&a[l]<=t+R)
			{
			    l++;
            }
			p=a[l-1];
			while(l<n&&a[l]<=p+R)
            {
                l++;
            }
			sum++;
		}
		cout<<sum<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
大学生就业服务平台管理系统按照操作主体分为管理员和用户。管理员的功能包括学生档案管理、字典管理、试卷管理、试卷选题管理、试题表管理、考试记录表管理、答题详情表管理、错题表管理、法律法规管理、法律法规收藏管理、法律法规留言管理、就业分析管理、论坛管理、企业管理、简历管理、老师管理、简历投递管理、新闻资讯管理、新闻资讯收藏管理、新闻资讯留言管理、学生信息管理、宣传管理、学生管理、职位招聘管理、职位收藏管理、招聘咨询管理、管理员管理。用户的功能等。该系统采用了Mysql数据库,Java语言,Spring Boot框架等技术进行编程实现。 大学生就业服务平台管理系统可以提高大学生就业服务平台信息管理问题的解决效率,优化大学生就业服务平台信息处理流程,保证大学生就业服务平台信息数据的安全,它是一个非常可靠,非常安全的应用程序。 管理员权限操作的功能包括管理新闻信息,管理大学生就业服务平台信息,包括考试管理,培训管理,投递管理,薪资管理等,可以管理新闻信息。 考试管理界面,管理员在考试管理界面中可以对界面中显示,可以对考试信息的考试状态进行查看,可以添加新的考试信息等。投递管理界面,管理员在投递管理界面中查看投递种类信息,投递描述信息,新增投递信息等。新闻信息管理界面,管理员在新闻信息管理界面中新增新闻信息,可以删除新闻信息。新闻信息类型管理界面,管理员在新闻信息类型管理界面查看新闻信息的工作状态,可以对新闻信息的数据进行导出,可以添加新新闻信息的信息,可以编辑新闻信息信息,删除新闻信息信息。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值