POJ - 3287 The Trip, 2007

问题描述:

A number of students are members of a club that travels annually to exotic locations. Their destinations in the past have included Indianapolis, Phoenix, Nashville, Philadelphia, San Jose, Atlanta, Eindhoven, Orlando, Vancouver, Honolulu, Beverly Hills, Prague, Shanghai, and San Antonio. This spring they are hoping to make a similar trip but aren’t quite sure where or when.

An issue with the trip is that their very generous sponsors always give them various knapsacks and other carrying bags that they must pack for their trip home. As the airline allows only so many pieces of luggage, they decide to pool their gifts and to pack one bag within another so as to minimize the total number of pieces they must carry.

The bags are all exactly the same shape and differ only in their linear dimension which is a positive integer not exceeding 1000000. A bag with smaller dimension will fit in one with larger dimension. You are to compute which bags to pack within which others so as to minimize the overall number of pieces of luggage (i.e. the number of outermost bags). While maintaining the minimal number of pieces you are also to minimize the total number of bags in any one piece that must be carried.

输入说明:

Standard input contains several test cases. Each test case consists of an integer 1 ≤ n ≤ 10000 giving the number of bags followed by n integers on one or more lines, each giving the dimension of a piece. A line containing 0 follows the last test case.

输出说明:

For each test case your output should consist of k, the minimum number of pieces, followed by k lines, each giving the dimensions of the bags comprising one piece, separated by spaces. Each dimension in the input should appear exactly once in the output, and the bags in each piece must fit nested one within another. If there is more than one solution, any will do. Output an empty line between cases.

SAMPLE INPUT:

6
1 1 2 2 2 3
0

SAMPLEOUTPUT:

3
1 2
1 2
3 2

思路:

有一堆袋子,小的可以装到大的里面,同样大小的没有办法进行操作,问我们如何装能够用最小的组合装完所有的袋子。先在输入时确定每个大小的袋子数cont,显然最大的那个数量就是我们所需要的组合数(应该大家都懂吧)那就从最小的袋子开始取,每次的间隔为cont(这样能够确保不会出现相同大小的袋子在同一组中)一共取n组(肯定可以取完,但每组的数量是不一样的)

AC代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,a,num[10005], sum[10005],cont=0,i,j;
    while (scanf("%d",&n)&&n!=0)
    {
        memset(num,0,sizeof(num));
        memset(sum,0,sizeof(sum));
        cont=0;
        for (i=0;i<n;i++)
        {
            cin>>sum[i];
            num[sum[i]]++;
            cont=max(cont,num[sum[i]]);
        }
        cout<<cont<<endl;
        sort(sum,sum+n);
        for (i=0;i<cont;i++)
        {
            for (j=i;j<n;j+=cont)
            {
                cout<<sum[j];
                if (j+cont<n)
                {
                cout<<' ';
                }
                else
                {
                    cout<<endl;
                }
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值