POJ - 3253 Fence Repair

问题描述:

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

输入说明:

Line 1: One integer N, the number of planks
Lines 2…N+1: Each line contains a single integer describing the length of a needed plank

输出说明:

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

SAMPLE INPUT:

3
8
5
8

SAMPLEOUTPUT:

34

思路:

题目已知切割一条木板的花费是他的长度,然后告诉我们一堆木板条的长度,然后问我们如何组合可以让切割木板的花费最低。实际的操作就是每次选择木板中最短的两根,然后将其的长度和加入花费中,再将其长度和加入队列中。
至于为什么用要用优先队列,一开始在循环中用的是sort然后报超时了,sort的时间复杂度是n*log2n,优先队列的则是logn,明显要快上一点。

AC代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int N,i,a[20001],m,n;
    long long sum=0;
    cin>>N;
    priority_queue<int,vector<int>,greater<int> >q;//priority queue的定义形式,这里定义的是一个递增的队列
    for (i=0;i<N;i++)
    {
        cin>>a[i];
        q.push(a[i]);//将元素a[i]加入队列中
    }
    while (q.size()>1)
    {
        m=q.top();q.pop();//top是取队列最的队首元素,pop是弹出队首元素,也就是把队首元素从队列中去除掉。
        n=q.top();q.pop();
        sum+=m+n;
        q.push(m+n);
    }
    cout<<sum;
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值