HDU - 4282 A very hard mathematic problem

问题描述:

Haoren is very good at solving mathematic problems. Today he is working a problem like this:
  Find three positive integers X, Y and Z (X < Y, Z > 1) that holds
   X^Z + Y^Z + XYZ = K
  where K is another given integer.
  Here the operator “^” means power, e.g., 2^3 = 2 * 2 * 2.
  Finding a solution is quite easy to Haoren. Now he wants to challenge more: What’s the total number of different solutions?
  Surprisingly, he is unable to solve this one. It seems that it’s really a very hard mathematic problem.
  Now, it’s your turn.

输入说明:

There are multiple test cases.
  For each case, there is only one integer K (0 < K < 2^31) in a line.
  K = 0 implies the end of input.

输出说明:

Output the total number of solutions in a line for each test case.

SAMPLE INPUT:

9
53
6
0

SAMPLEOUTPUT:

1
1
0

Hints:

9 = 1^2 + 2^2 + 1 * 2 * 2
53 = 2^3 + 3^3 + 2 * 3 * 3

思路:

题目的要求是让我们解一个方程,并求出一共有多少组解,输出解的数量。
乍一看很难想到怎么用二分去做,仔细想一下,我们可以发现一共有3个未知数,显然,如果对他们都进行二分或者三分是不现实的,所以我们选择枚举x和z,二分搜索合适的y值。此外还有一些需要注意的点,一是z 的取值范围,z是作为上标出现的,其最大值是有限制的(小于32)二是在乘方运算时需要使用快速幂,否则无论时循环求解还是pow求解,时间复杂度都比较高,会tle,因此要使用快速幂的方法。

AC代码:

#include <bits/stdc++.h>
using namespace std;
long long pow(long long a,long long n)
{
    long long  sum=1;
    long long  temp=a;
    while(n)
    {
        if(n&1)sum*=temp;
        temp*=temp;
        n>>=1;
    }
    return sum;
}
int main()
{
    long long k;
    long long ans;
    while(scanf("%d",&k)&&k)
    {
        ans=0;
        long long temp=(long long)sqrt(k);
        if(temp*temp==k)
            ans+=(temp-1)/2;
        for(long long z=3;z<31;z++)
        {
            for(long long x=1;;x++)
            {
                long long u=pow(x,z);
                if(u*2>=k)
                    break;
                for(long long y=x+1;;y++)
                {
                    long long v=pow(y,z);
                    if(u+v+x*y*z>k)
                        break;
                    if(u+v+x*y*z==k)
                        ans++;
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值